InfoSphere Information Server, Version 9.1 fails to install on Solaris 9

Technote (troubleshooting)


Problem(Abstract)

Trying to install InfoSphere Information Server 9.1 on Solaris 9 causes the installation to fail with the following error:
error ld.so.1: solid: fatal: libm.so.2: open failed: No such file or directory

Symptom

An error message similar to the following is reported in the prompt. On the Solaris 9 operating system you can receive this error if you install InfoSphere Information Server, Version 9.1:

ld.so.1: solid: fatal: libm.so.2: open failed: No such file or directory


Cause

InfoSphere Information Server, Version 9.1 is built on Solaris 10, so it links with libm.so.2. On Solaris 9, 'libm.so.2' is not available.

On Solaris 9 libm.so.1 (an older version of the libm library) is used.


Resolving the problem

InfoSphere Information Server, Version 9.1 is only supported on Solaris 10. Upgrade your operating system and retry the installation.

Product Alias/Synonym

InfoSphere Information Server 9.1

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

InfoSphere Information Server

Software version:

9.1

Operating system(s):

Solaris

Reference #:

1607914

Modified date:

2012-11-26

Translate my page

Machine Translation

Content navigation