Troubleshooting
Problem
When you have enabled Kerberos security, the following exception might be seen in SystemOut.log of the DataService Cluster members. KRBAuthnToken E CWWSS5520E: An exception occurred during token processing. The exception is: org.ietf.jgss.GSSException, major code: 8, minor code: 0 major string: Credential expired minor string: Kerberos credential has expired at com.ibm.security.jgss.i18n.I18NException.throwGSSException(I18NException.java:7)
Cause
When the WebSphere Application Server creates a scheduler. it saves the Kerberos security subject in a scheduler table.
WebSphere Application Server does not update this Kerberos security subject until the scheduler is cancelled.
When the Kerberos ticket is expired and the scheduler runs a scheduling task, the WebSphere Application Server logs the exception in the SystemOut.log.
Environment
Integrated Information Core 1.5
Resolving The Problem
Login to WebSphere Administrative Console.
- Go to Resources > Schedulers > SubscriptionScheduler
- In Related Items, click Work managers
- In Scope, select Cluster=IICDASvcs, and then click New
- Name : subscriptionWorkManager
- JNDI : wm/subscriptionWorkManager
- Deselect Security
- Select Internationalization
- Select WorkArea
- Click Ok
- Go to Resources > Schedulers > SubscriptionScheduler
- Change Work manager JNDI name to wm/subscriptionWorkManager
- Click Ok, and then Save configuration.
- Go to Resources > Cluster, Stop IICDASvcs
- Go to Resources > Schedulers
- Select SubscriptionScheduler, and then click Drop tables
- When Drop tables is successful, click Create tables.
- Synchronize all Nodes.
- Restart IICDASvcs Cluster
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Document Information
Modified date:
17 June 2018
UID
swg21607604