A .zip file import to the XML schema library on a Japanese version of Microsoft Windows operating system fails with an error message

Technote (troubleshooting)


Problem(Abstract)

A .zip file fails to import to the XML schema library when the .zip file, created by the ZIP utility of the Japanese version of the Microsoft Windows operating system, encounters either or both of the following conditions:

> The .zip file contains XML schemas with Japanese name.
> The .zip file name contains Japanese characters.

Symptom

A .zip file import to the XML schema library fails with an error message.


Cause

The XML stage internally uses the jar command to decompress a .zip file. The jar command used to decompress the .zip file expects the names in the archive to be encoded in UTF-8. A conversion error occurs if the file names in the archive are encoded in encodes other than the UTF-8.

When a .zip file is created using the ZIP utility provided by the Japanese version of the Microsoft Windows system, and the jar command is used to decompress the file, the Japanese file names in the archive are encoded in Shift_JIS. This results in a conversion error when you try to import that .zip file to the XML schema library.

This issue is a limitation of the XML Stage for release 8.7.


Environment

Japanese version of Microsoft Windows operating system.

Resolving the problem

Unzip the .zip file and try to import the files one at a time.

Alternatively, you can recreate the .zip file by using the jar command, without using the Windows ZIP utility.


Cross reference information
Segment Product Component Platform Version Edition
Information Management InfoSphere Information Server 9.1, 8.7.0.2, 8.7.0.1, 8.7

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Document information


More support for:

InfoSphere DataStage

Software version:

8.7

Operating system(s):

Windows

Reference #:

1607557

Modified date:

2012-12-06

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