Troubleshooting
Problem
Installation or upgrade of IBM Rational ClearQuest (CQ), IBM Rational ClearCase (CC) or IBM Rational RequisitePro (ReqPro) versions 7.1.1.6 - 7.1.2.3 or later fails with the error message "status=1603" when the installer tries to install the Global Security Kit (GSKit) package.
Symptom
The IBM Installation Manager install operation fails with an error similar to the following:
Error occurred in phase: install
SU: ibm.gskit7 7.1.1006.0000-7-1-1-06-00-2011B-D110330
IU: ibm.gskit7.iu 999.999.999.-801196304->999.999.999.890104693
Message: Error executing "C:\Windows\system32\msiexec.exe" operation
(status=1603).
See agent output log for more information: C:
\ProgramData\IBM\Installation Manager\logs\native\20120417_1208c.log
In the installation log, the cause of the failure is Microsoft Installer (MSI) error code 1603. If the MSI log (gsk7install.log) was captured, users might also notice the following messages in the MSI log:
: Failed to create script engine...
1: Script Handler initialization failed, error = 0x0
followed by this text:
Action start 18:18:00: GSKQueryInstallPath.
1: f1: Function failed, the user might cancel the installation.
CustomAction GSKQueryInstallPath returned actual error code 1603 (note this may
not be 100% accurate if translation happened inside sandbox)
Action ended 18:18:00: GSKQueryInstallPath. Return value 3.
Note: The default location for the MSI log is in the defined %TEMP% directory.
Cause
The MSI installer for the GSKit MSI package has an issue handling certain conditions on Windows 7 platforms.
This issue was identified as a product defect and logged under APAR PM69850
Environment
Windows 7, both 32-bit and 64-bit
Resolving The Problem
This issue has been resolved in version 8.0.x of Rational ClearQuest, Rational ClearCase and in version 7.1.3.x of Rational RequisitePro.
IMPORTANT: Before applying the workaround, it is strongly recommended to migrate the product to 8.0.x of Rational ClearQuest, Rational ClearCase or 7.1.3.x of Rational RequisitePro, since this is the best way to fix the problem.
WORKAROUND
- Update
- Clean Install
- Using IBM Installation Manager, uninstall any Rational Offering (ClearCase, ClearQuest or ReqPro) instance that could appeared as installed.
- Verify that GSKit is no longer installed, (Go to Windows Control Panel and look for installed software). If GSkit is still installed, then manually uninstall it from there.
- Once the system is in a clean state (no Rational Offering nor GSKit installed) then attempt to install from scratch ClearQuest, ClearCase or ReqPro by adding to Installation Manager the base repository (e.g. 7.1.2) and its Fix Pack repository (e.g. 7.1.2.14); both repositories must be enabled.
- The install process should complete successfully.
- Henceforth the product must be able to be updated without problem to new versions.
If the update is the only way you can proceed, then you must contact IBM Support to receive a step by step guidance to resolve the problem, otherwise you can attempt to uninstall and cleanly re-install your product as the next bullet describes it.
The machine must be completely "clean" before the installation; if previous installs have been performed, you must follow these steps to ensure a clean state of the machine before you proceed with the installation:
Related Information
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Document Information
Modified date:
16 June 2018
UID
swg21607513