Technote (troubleshooting)
Problem(Abstract)
After restarting the NMTN process the log file fills with the following errors:
01 May 2012 14:21:59 INFO FaultLogger *** Timed out. Must flush the queue to the logs.
01 May 2012 14:22:09 INFO FaultLogger *** Timed out. Must flush the queue to the logs.
01 May 2012 14:22:19 INFO FaultLogger *** Timed out. Must flush the queue to the logs.
01 May 2012 14:22:29 INFO FaultLogger *** Timed out. Must flush the queue to the logs.
Cause
This generally happens when nmtn_server is
started up on secondary mode. When starting on secondary mode,
nmtn_server will read the configuration fine
$NCHOME/etc/precisiontn/secondary.xml, which expects connection to
Omnibus
<!-- 3. Set the parameters -->
<properties name="LEAPFramework">
<property name="lumos.leap.service.opl.Enable"
value="true" />
</properties>
Since the nmtn_server could not find the Omnibus ObjectServer, it timed
out and logs it into nmtn_server log
Resolving the problem
To specifically suppress this log, the customer can set the FaultLogger level in $NCHOME/etc/precisiontn/nmtn_server_trace.properties to WARN (as below)
log4j.category.ilumos.leap.service.fault.FaultLogger=WARN
Reload the trace file through NMTN GUI :
To reload the trace configuration files, follow these steps:
1. On the Network Manager (TN) Admin page, click the System tab.
2. Select Reload Trace.
3. In the Domain field, select the name of your Network Manager Transmission Edition domain. By default the domain is NMTN.
4. Click Reload.
Wait for a couple of minutes and the message shouldn't be logged anymore.
Rate this page:
Copyright and trademark information
IBM, the IBM logo and ibm.com are trademarks of International Business Machines Corp., registered in many jurisdictions worldwide. Other product and service names might be trademarks of IBM or other companies. A current list of IBM trademarks is available on the Web at "Copyright and trademark information" at www.ibm.com/legal/copytrade.shtml.