Troubleshooting
Problem
A BIRT report runs against a large record result set and exceeds more than 1 or 2 minutes; the report may fail with the following error: org.eclipse.birt.report.service.api.ReportServiceException
Cause
It will only occur when there is a clustered WebSphere environment. It does not always depend on the number of records but length of time for running report as well.
Resolving The Problem
Edit the ServerIOTimeout parameter within your Web server(s) in WAS under:
Servers -> Server Types -> Websphere Application Servers -> Click on [server_name] -> Web server plug-in properties (under 'Additional Properties') -> Read/Write timeout.
Increase this value accordingly until you no longer see errors running reports. Make this change to all JVMs necessary.
After making this change, be sure to re-generate and propagate the plugin-cfg.xml under:
Servers -> Server Types -> Websphere Servers
and clicking the Generate Plug-in, then Propagate Plug-in and restarting the server.
Check the new plugin-cfg.xml on your web server to ensure the change has made it to the web server.
Test by running a lengthy report..
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Document Information
Modified date:
17 June 2018
UID
swg21607119