Events such as AFTER_CREATE_CUSTOMER, AFTER_MODIFY_CUSTOMER and AFTER_DELETE_CUSTOMER raised even upon call to receiveCustomerChanges API

Technote (FAQ)


Question

How are events such as AFTER_CREATE_CUSTOMER, AFTER_MODIFY_CUSTOMER and AFTER_DELETE_CUSTOMER raised even upon call to receiveCustomerChanges API, though they are not mentioned in the API javadocs, documentation?

Cause

This has been identified as a document defect under APAR IC85624

Answer

The general understanding is that when we pass Operation as ="Create" in the Customer Element of the input XML of receiveCustomerChanges API, it passes through the Define Customer Transaction. i.e. Upon successful customer creation, the events that have been activated under the Define Customer transaction, such as AFTER_CREATE_CUSTOMER is invoked.

Note that this event (or other events related to the "Define Customer" transaction) is not mentioned under the receiveCustomerChanges API javadocs description.

Even if the receiveCustomerChanges API is being used as a wrapper API to create new customer through the same transaction “Define Customer”, it is required to have information regarding the events that could be raised upon Customer Creation, Modification such as AFTER_CREATE_CUSTOMER, AFTER_MODIFY_CUSTOMER and AFTER_DELETE_CUSTOMER documented under the Events Raised section of the receiveCustomerChanges API.

Or a note mentioning that receiveCustomerChanges API internally calls manageCustomer API, hence the events raised as part of manageCustomer will be raised for receiveCustomerChanges also.

After discussions with Engineering on this issue, a Documentation Defect has been raised. The above points are to be included in the documentation.


Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

Sterling Order Management

Software version:

All

Operating system(s):

All

Reference #:

1607044

Modified date:

2012-10-21

Translate my page

Machine Translation

Content navigation