Troubleshooting
Problem
In some situtations -- such as restoring from backup filesystem and not restoring xmeta -- 'ghost jobs' may appear in InfoSphere Information Server.
Symptom
There are a few symptoms:
- jobs are visible in DataStage Designer and not visible in DataStage Director
- error 'cannot find job #jobname#' while opening the job in the DataStage Designer
- error message '(40503) A call to an OLE server has failed, or a runtime error occurred within the OLE server itself' during compilation of the job
Cause
During restoring of InfoShpere Information Server xmeta backup was not restored.
Resolving The Problem
Information on DataStage jobs is stored in 2 locations, on disk in the project directory and in the xmeta metadata repository. Those locations must be kept in sync -- If you restore one from backup but not the other, you may have some jobs which appear in Designer but not Director client, or vice versa.
To solve the problem please do either you can restore both the Information Server disk directories (including projects) to same restore point as the xmeta database (with the understanding that any content added after that backup date will be lost), or you can use the SyncProject tool to synchronize the job definitions between disk and database.
The SyncProject tool can be run directly as documented in the product manual, or started via the ISALite tool using the options below:
Utilities -> Detect and remove invalid Information Server 8.0.1/8.1 DataStage projects or
Utilities -> Detect issues, view issues, and fix invalid Information Server 8.5/8.7 DataStage
ISALite can be found here: http://www.ibm.com/support/docview.wss?rs=14&uid=swg24022700
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Document Information
Modified date:
16 June 2018
UID
swg21606799