Ghost jobs appear in InfoSphere Information Server

Technote (troubleshooting)


Problem(Abstract)

In some situtations -- such as restoring from backup filesystem and not restoring xmeta -- 'ghost jobs' may appear in InfoSphere Information Server.

Symptom

There are a few symptoms:

- jobs are visible in DataStage Designer and not visible in DataStage Director

- error 'cannot find job #jobname#' while opening the job in the DataStage Designer

- error message '(40503) A call to an OLE server has failed, or a runtime error occurred within the OLE server itself' during compilation of the job

Cause

During restoring of InfoShpere Information Server xmeta backup was not restored.

Resolving the problem

To solve the problem please do either:

- restore from backup xmeta database and file system from the same point of time

or

- use DStageWrepper.sh script as described here: http://publib.boulder.ibm.com/infocenter/ieduasst/imv1r0/index.jsp?topic=/com.ibm.iea.infosphere_is/infosphere_is/8.5/configuration/ManuallyDeleteDS_Job/player.html

or

- use ISALite

Utilities -> Detect and remove invalid Information Server 8.0.1/8.1 DataStage projects or
Utilities -> Detect issues, view issues, and fix invalid Information Server 8.5/8.7 DataStage

ISALite can be found here: http://www.ibm.com/support/docview.wss?rs=14&uid=swg24022700

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

InfoSphere Information Server

Software version:

8.0, 8.0.1, 8.0.1.1, 8.0.1.2, 8.0.1.3, 8.0.2, 8.1, 8.1.0.1, 8.1.0.2, 8.1.2.5, 8.5, 8.5.0.1, 8.5.0.2, 8.7, 8.7.0.1

Operating system(s):

AIX, HP-UX, Linux, Solaris, Windows

Reference #:

1606799

Modified date:

2012-11-16

Translate my page

Machine Translation

Content navigation