IBM Support

Table contains unrecoverable events in WebSphere Business Monitor

Troubleshooting


Problem

If the number of unrecoverable events build up to a large value, it becomes difficult to delete them from the WebSphere Application Server admin graphical user interface.

Symptom

Unable to delete unrecoverable events from admin console due to large number of unrecoverable events.

Cause

Large volume of unrecoverable events.

Environment

All

Diagnosing The Problem

Deleting events does not work via the graphical user interface because of a large volume of unrecoverable events.

Resolving The Problem

Delete the unrecoverable events in the DQ_DEAD_EVENT_T table.

Alternative unsupported methods:
The MBean instance of type "DeadQ" on the DMGR node may have an operation "deleteAllEvents" that takes a string argument, corresponding to a generated GUID that exists in the DQ_MODEL_VERSION_T table.

You may be able to retrieve via the getModelVersion operation on the same MBean.

[{"Product":{"code":"SSSRR3","label":"WebSphere Business Monitor"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"--","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"7.0.0.5;7.0.0.4;7.0.0.3;7.0.0.2","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}},{"Product":{"code":"SS7NQD","label":"IBM Business Monitor"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Not Applicable","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"","label":"Linux zSeries"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"7.5.1;7.5","Edition":"","Line of Business":{"code":"LOB36","label":"IBM Automation"}}]

Document Information

Modified date:
15 June 2018

UID

swg21606709