Troubleshooting
Problem
Using the Self Service Center in SRM with Service Provider (SP) to view Offerings, customer A can see the catalog offerings from customer B.
Symptom
This is most noticeable when customer A catalog has been set to Pending status.
This does not happen when using the standard Maximo interface. That is, the standard Offering Catalog instead of the Self Service Center does not do this.
Cause
The Caching Proxy server that is before the IHS server is caching the requests.
Diagnosing The Problem
Check the IHS access log. If you are seeing the request for customer B information but not the request for customer A, it proves the Caching Proxy server has intercepted the request.
Resolving The Problem
The Cachine Proxy server needs to have Caching turned off if you are hosting a JVM that servers more than one customer. This essential makes it a Reserse Proxy.
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Document Information
Modified date:
27 February 2019
UID
swg21606557