IBM Support

Error message when opening Contributor Application on Cognos Connection: Authentication Token Invalid

Troubleshooting


Problem

When opening any Contributor application package on Cognos Connection the following error appears with no changes to the environment and the environment was working fine prior to the error now appearing.

Symptom

Authentication Token Invalid
OK
Select OK, one will be prompted with a Retry link to select.
Select Retry and the message defaults back to the error message.


NOTE:

If there is more then one Planning Server in the Environment and more then one server has the Planning Web Service enabled when the user selects OK to the error message and then selects Retry link, the workflow page for the Contributor application now appears fine and the application is fully accessible as it round robins to the next available server running the Planning Web Service.

Cause

Cryptographic keys are out of sync and Planning service can not decrypt authentication details received from the Cognos BI server

Environment

Distributed Planning and BI environment

Diagnosing The Problem

Open Cognos Configuration on the Cognos Planning Server and press the Save button.
Verify if there are no issues and configuration has been saved.
If there is any issue cryptographic keys need to be recreated.

OR

FURTHER TROUBLESHOOTING:

1. If more then one Planning Server in the environment, open up Cognos Configuration on each server.
2. Confirm if more then one server has the Planning Web Service (PWS) enabled.
3. If so, disable the PWS service on all but one server and test to see which server is the culprit.
4. The problem server with the PWS enabled, when selecting the Retry link, the error Authentication Token Invalid will appear again as the other servers have the PWS disabled and thus, no round robin occurs.
5. Once the culprit server is found, Regenerate the Cryptogrpahic keys on the one problem Planning server, there is no requirement to regenerate the keys on all servers.

Resolving The Problem

Regenerate cryptographic keys as per instruction below:
http://www-01.ibm.com/support/docview.wss?uid=swg21383421

[{"Product":{"code":"SSPN2D","label":"Cognos Planning"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Contributor","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.1;10.1.1","Edition":"All Editions","Line of Business":{"code":"LOB10","label":"Data and AI"}},{"Product":{"code":"SSPN2D","label":"Cognos Planning"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Contributor","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.1;10.1.1","Edition":"Advanced;All Editions;Edition Independent;Enterprise;Personal;Standard;Workgroup;Workstation","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21606396