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DPR-ERR-2109 The dispatcher cannot service the request at this time. The dispatcher is still initializing.

Troubleshooting


Problem

- When users try to login from Cognos Connection, they hit the following error : DPR-ERR-2109 The dispatcher cannot service the request at this time. The dispatcher is still initializing. Contact your administrator if this problem persists. Please try again or contact your administrator. - No one can connect to the Cognos environment from Cognos Connection. - The dispatcher service appears to be started, but the pogo logs show errors

Symptom

The pogo logs show the following error message :

2012-07-20 15:07:41.131 DEBUG [.cognos.pogo.impl.PogoSOAPMessageResponder] http-19300-1: Sending response: <?xml version="1.0" encoding="UTF-8"?>

<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:bus="http://developer.cognos.com/schemas/bibus/3/" SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/">
<SOAP-ENV:Header>
<bus:biBusHeader xsi:type="bus:biBusHeader">
<bus:tracking xsi:type="bus:tracking"/>
<bus:dispatcherTransportVars xsi:type="SOAP-ENC:Array" SOAP-ENC:arrayType="bus:dispatcherTransportVar[]">
<item xsi:type="bus:dispatcherTransportVar">
<name xsi:type="xsd:string">html</name>
<value xsi:type="xsd:string">false</value>
</item>
</bus:dispatcherTransportVars>
</bus:biBusHeader>
</SOAP-ENV:Header>
<SOAP-ENV:Body>
<SOAP-ENV:Fault>
<faultcode>Server</faultcode>
<faultstring>The server did something wrong</faultstring>
<detail>
<bus:exception>
<severity>error</severity>
<errorCode>DISPATCHER_NOT_YET</errorCode>
<bus:message>
<messageString>DPR-ERR-2109 The dispatcher cannot service the request at this time. The dispatcher is still initializing. Contact your administrator if this problem persists.</messageString>
<nestingLevel>1</nestingLevel>
</bus:message>
</bus:exception>
</detail>
</SOAP-ENV:Fault>
</SOAP-ENV:Body>
</SOAP-ENV:Envelope>

2012-07-20 15:07:41.146 DEBUG [ com.cognos.pogo.services.ServiceFactory] Thread-19: creating pogo service batchReportService of type com.cognos.pogo.services.SoapActionHandlerService
2012-07-20 15:07:41.146 WARN [ com.cognos.pogo.config.XMLConfigurator] Thread-19: Error while processing service xml file /WEB-INF/services/batchreportservice.xml com.cognos.pogo.pdk.InvalidServiceException
at com.cognos.pogo.pdk.DefaultService.checkProperty(DefaultService.java:150)
at com.cognos.pogo.pdk.DefaultService.checkForPrerequisites(DefaultService.java:103)
at com.cognos.pogo.pdk.DefaultService.contextualize(DefaultService.java:77)
at com.cognos.pogo.services.HandlerReadingService.contextualize(HandlerReadingService.java:37)
at com.cognos.pogo.services.SoapActionHandlerService.contextualize(SoapActionHandlerService.java:32)
at com.cognos.pogo.config.XMLConfigurator.configureService(XMLConfigurator.java:235)
at com.cognos.pogo.config.XMLConfigurator.configureFile(XMLConfigurator.java:218)
at com.cognos.pogo.config.XMLConfigurator.configureFromResources(XMLConfigurator.java:122)
at com.cognos.pogo.config.XMLConfigurator.configure(XMLConfigurator.java:64)
at com.cognos.pogo.transport.PogoServlet$PogoStartup.run(PogoServlet.java:687)
at com.cognos.pogo.util.threads.SafeThread.safeRun(SafeThread.java:70)
at com.cognos.pogo.util.threads.SafeThread.run(SafeThread.java:61)

- From cogserver.log log file, there is the following error:

PRS-BST-1604 The XTS engine is stopped.

Cause

The file "<c10_Installation_directory>\templates\ps\cogadmin\system.xml" was corrupted.

Resolving The Problem

- From a Dos window, ran the following command from the <c10_Installation_directory> folder:

dir /a-d-h /od /s > filesorted.txt

The DOS command above will display all the files (including in the subfolders) and will sort them by date in each folder. The whole output will be saved in a file named filesorted.txt .

- The output above helped to see that in folder "<c10_Installation_directory>\templates\ps\cogadmin", the size of the system.xml file was 0 KB. This file has been corrupted somehow.

- Renamed system.xml to system.xml.old and a backup file from this directory (system.xml.bkp.1342134240822) to system.xml

- Restarted the services.

[{"Product":{"code":"SSEP7J","label":"Cognos Business Intelligence"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Install and Config","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.2.2;10.2.1;10.2;10.1.1;10.1","Edition":"All Editions","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21606018