Skip to main content

Internal Server Error when importing or previewing transactions in the UI


Technote (troubleshooting)


Problem(Abstract)

When using the Import Preview feature in the External Systems application or importing using the new Application Import feature you may see an Internal Server Error if the import or preview takes longer than 60 seconds.

Cause

In the default configuration for the WebSphere HTTP Server plugin there is a ServerIOTimeout setting which by default is set to 60 seconds. If a dialog box is performing an operation and there is no user activity for this time, the error is thrown and the page must be refreshed.

It is worth noting that this does not effect the transaction being successfully processed by the application.


Resolving the problem

To resolve the problem you should open the WebSphere Administration Console.

Go to Sever Types, WebSphere Application Servers, MXServer (or whatever you server is called), Web Server Plug-in properties, change the Read/Write Timeout in seconds.

You can set this higher or you can set this to 0 to disable the time-out

Then generate and propagate a new plugin configuration.

Alternatively locate the plugin-config.xml file in the following directory where your HTTP Server is installed:

<HTTP_Server_Root>\plugins\config\webserver1\

In this file you will find the following section:


<ServerCluster CloneSeparatorChange="false" GetDWLMTable="false" IgnoreAffinityRequests="true" LoadBalance="Round Robin" Name="MXServer_ctgNode01_Cluster" PostBufferSize="64" PostSizeLimit="-1" RemoveSpecialHeaders="true" RetryInterval="60">
<Server ConnectTimeout="5" ExtendedHandshake="false" MaxConnections="-1" Name="ctgNode01_MXServer" ServerIOTimeout="60" WaitForContinue="false">
<Transport Hostname="max75w2k8.local" Port="9080" Protocol="http"/>
<Transport Hostname="max75w2k8.local" Port="9443" Protocol="https">
<Property Name="keyring" Value="C:\IBM\HTTPServer\Plugins/config/webserver1/plugin-key.kdb"/>
<Property Name="stashfile" Value="C:\IBM\HTTPServer\Plugins/config/webserver1/plugin-key.sth"/>
</Transport>
</Server>
</ServerCluster>

Notice the ServerIOTimeout setting in bold.

You can set this higher or you can set this to 0 to disable the time-out. However the Generate and Propagate process from the Admin Console above would wipe this change out.

Cross reference information
Segment Product Component Platform Version Edition
Systems and Asset Management IBM SmartCloud Control Desk

Rate this page:

(0 users)Average rating

Copyright and trademark information

IBM, the IBM logo and ibm.com are trademarks of International Business Machines Corp., registered in many jurisdictions worldwide. Other product and service names might be trademarks of IBM or other companies. A current list of IBM trademarks is available on the Web at "Copyright and trademark information" at www.ibm.com/legal/copytrade.shtml.

Rate this page:


(0 users)Average rating

Add comments

Document information

IBM Maximo Asset Management

MEA: Generic


Software version:
7.5


Operating system(s):
AIX, HP-UX, Linux, Solaris, Windows


Reference #:
1605774


Modified date:
2013-02-08

Translate my page

Content navigation