Skip to main content

Invalid or missing password errors


Technote (troubleshooting)


Problem(Abstract)

Optim clients attempting to run requests on a unix server report invalid or missing password errors.

Symptom

PR0SVER trace file shows invalid or missing password error on connection to database.


Cause

The customer name, formal customer name, or license key do not match between Windows client and the pstserv.cfg file on the server.

Environment

This may occur to Optim running on AIX, Linux, Sun or HP Unix machines. This could also occur for any database: DB2, Oracle, Sybase, Informix, or Teradata.

pstlogon and/or dbaliaslogon in pstserv.cfg will be set to client


Resolving the problem

Ensure the Customer name, Formal Customer name, Customer ID and License Key match what was provided in the Optim License.


If the 'customername' and 'customerformalname' in the pstlocal and pstserv files on the UNIX/LINUX server match with what has been provided on Windows in the Optim Configuration GUI -- OPTIONS --COMPANY NAME screen, then check if multiple DBALIAS definitions have been created for the same database, if yes drop all DBALAIS definitions for the database and then create just one.


Rate this page:

(0 users)Average rating

Copyright and trademark information

IBM, the IBM logo and ibm.com are trademarks of International Business Machines Corp., registered in many jurisdictions worldwide. Other product and service names might be trademarks of IBM or other companies. A current list of IBM trademarks is available on the Web at "Copyright and trademark information" at www.ibm.com/legal/copytrade.shtml.

Rate this page:


(0 users)Average rating

Add comments

Document information

Optim


Software version:
8.1


Operating system(s):
AIX, HP Itanium, HP-UX, Linux, Solaris


Reference #:
1605708


Modified date:
2012-11-08

Translate my page

Content navigation