SmartCloud APM UI installation fails - could not find a valid java

Technote (FAQ)


Question

Launching install.exe to attempt to install IBM SmartCloud APM UI v7.5 fails with message : "Could not find a valid Java virtual machine to load. You may need to reinstall a supported Java virtual machine"

Cause

Your PATH environment variable doesn't contain a path to a Java version 1.6 environment

Answer

TIP v2.2 includes a Java v1.6 environment in <TIP HOME>\tipv2\java\jre\bin

And SmartCloud APM UI installation prereqs Java v1.6

so set PATH variable in a command window, like for example : PATH=C:\IBM\tivoli\tipv2\java\jre\bin

then relaunch install.exe from a command window. This time, the installer should find a valid Java environment and continue the installation successfully.


Cross reference information
Segment Product Component Platform Version Edition
Systems and Asset Management IBM SmartCloud Application Performance Management IBM SmartCloud Application Performance Management UI AIX, Linux/x86, Windows, Windows 7 7.5.0

Product Alias/Synonym

ITCAM ITCAM4Tx SmartCloud APMUI

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

Tivoli Composite Application Manager for Transactions

Software version:

7.3

Operating system(s):

Windows

Reference #:

1605336

Modified date:

2013-01-29

Translate my page

Machine Translation

Content navigation