IBM Support

Security Bulletin: Security vulnerabilities fixed in IBM WebSphere Operational Decision Management and IBM WebSphere ILOG JRules

Flash (Alert)


Abstract

List of security vulnerabilities fixed in WebSphere Operational Decision Management V7.5 and V8.0 and WebSphere ILOG JRules 7.1

Content

VULNERABILITY DETAILS:

  • CVE ID: CVE-2012-2161

    DESCRIPTION: The IEHS (IBM Eclipse Help System) component has a cross-site scripting vulnerability

    CVSS:

    CVSS Base Score: 4.3
    CVSS Temporal Score
    : See https://exchange.xforce.ibmcloud.com/vulnerabilities/74833 for the current score
    CVSS Environmental Score*
    : Undefined
    CVSS String
    : (AV:N/AC:M/Au:N/C:N/I:P/A:N)

  • CVE ID: CVE-2012-2159

    DESCRIPTION: The IEHS (IBM Eclipse Help System) component has an open redirect vulnerability.

    CVSS:

    CVSS Base Score: 4.3
    CVSS Temporal Score
    : See https://exchange.xforce.ibmcloud.com/vulnerabilities/74832 for the current score
    CVSS Environmental Score*
    : Undefined
    CVSS String
    : (AV:N/AC:M/Au:N/C:N/I:P/A:N)

    AFFECTED PLATFORMS:
  • WebSphere Operational Decision Management Version 7.5.0.0 through 8.0.0.0
  • WebSphere ILOG JRules 7.0.0 through 7.1.1.4
  • WebSphere ILOG Rules For Cobol 7.0.0 through 7.1.1.4
  • WebSphere ILOG Rules for z/OS 7.0.0 through 7.1.1.4

    REMEDIATION:

    Apply the fix for each named product as soon as practical. See below for information about the fixes available

    FIX:

    For IBM WebSphere Operational Decision Management

    For V8.0
  • Install Interim Fix 1 fixing APAR RS01040
    or
  • Install Fix Pack 1 (8.0.0.1) or later.

    For V7.5
  • Install Fix Pack 2 (7.5.0.2)
  • Install Interim Fix 7 fixing APAR RS01034
    or
  • Install Fix Pack 3 (7.5.0.3) or later.


    For WebSphere ILOG JRules
    For WebSphere ILOG Rules for COBOL
    For WebSphere ILOG JRules for z/OS

    For V7.0 through V7.1.1.3
  • Install Fix Pack 4 (7.1.1.4)
  • Install WebSphere ILOG JRules Interim Fix 12 fixing APAR RS00996, RS000995, PB00089
    or
  • Install Fix Pack 5 (7.1.1.5) or later.

    Workaround: None



    REFERENCES:
    · Complete CVSS Guide https://www.first.org/cvss/v2/guide
    · On-line Calculator V2 http://nvd.nist.gov/cvss.cfm?calculator&adv&version=2

    Note: According to the Forum of Incident Response and Security Teams (FIRST), the Common Vulnerability Scoring System (CVSS) is an "industry open standard designed to convey vulnerability severity and help to determine urgency and priority of response." IBM PROVIDES THE CVSS SCORES "AS IS" WITHOUT WARRANTY OF ANY KIND, INCLUDING THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. CUSTOMERS ARE RESPONSIBLE FOR ASSESSING THE IMPACT OF ANY ACTUAL OR POTENTIAL SECURITY VULNERABILITY.


  • Cross reference information
    Segment Product Component Platform Version Edition
    Business Integration WebSphere ILOG JRules for z/OS
    Business Integration WebSphere ILOG JRules
    Business Integration WebSphere ILOG Rules for COBOL

    Document information

    More support for: IBM Operational Decision Manager
    General

    Software version: 7.5, 7.5.0.1, 7.5.0.2, 8.0

    Operating system(s): Platform Independent

    Reference #: 1600616

    Modified date: 05 July 2012


    Translate this page: