Technote (troubleshooting)
Problem(Abstract)
Attempts to create the IBM Informix IDS service on Microsoft Windows fails with error "Failed on initializing Disk Space and Shared Memory" for IBM Rational Synergy.
Symptom
Following a Rational Synergy install, the Informix IDS service does not start and the Informix Server Creation process will fail.
The Informix Server creation process shows the following messages:
Initializing Disk Space and Shared Memory, please wait .................................
ERROR: Failed on initializing Disk Space and Shared Memory.
Clean up database server's files....
The Windows Event Viewer may show entries such as;
error:1069: The service did not start due to a logon failure
If you try subsequently to create a database server using the
ccmsrv create command, this will fail with similar error messages.
Cause
During the creation of the Rational Synergy database server, the install process tries to start the Informix IDS service to create and install the schema and master database. If Informix IDS does not come online the process will abort and a cleanup phase is initiated. The database server is not created.
It is necessary for the database server create process that the installer is able to start the Informix IDS service.
The Infoirmix IDS Service is configured to run as the informix user. The message; error:1069 The service did not start due to a logon failure usually indicates a logon failure for the informix account.. This most probably is due to the fact that the user does not have the required Log on as a Service right, but it might also be caused by anti-virus software restrictions.
Another possible cause of this problem is that the TEMP and/or TMP directory is not writable by the current user.
Environment
Windows Active Directory Domain
Diagnosing the problem
The Informix IDS server creation process in the Rational Synergy install.log shows the following messages:
Initializing Disk Space and Shared Memory, please wait .................................
ERROR: Failed on initializing Disk Space and Shared Memory.
Clean up database server's files....
The Windows Event Viewer may show entries such as:
error:1069: The service did not start due to a logon failure Check that the currently logged on user can create files in [
%TEMP% and in
%TMP% by running the commands:
copy nul %TEMP%\x
copy nul %TMP%\x
Resolving the problem
Apply one or more of the following solutions below to resolve the issue:
- Ensure when using Windows commands
gpedit.mscorsecpol.msc /sor in your Local Policies > User Rights Assignments that the user informix has the following rights:
Act as part of the operating systemAdjust memory quotas for a processDebug programsLog on as a serviceLog on locallyManage auditing and security logReplace a process level token
Note: Even if you set these User Rights policies locally, you may still need to ensure the client has not inherited a conflicting or opposite policy from the domain Group Policy. In Windows, where there is a policy conflict, the lower privilege will apply. You can check the effective policy by going to Start > Run and typinggpedit.mscon the client, and then browsing to the policy.
- Add the
oninitandonscpahprocesses to the exceptions list in your Anti Virus configuration
- Set your
TEMPandTMPenvironments to a fully writable directory path.
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