IBM Support

"Internal error ... manager\.fileTableLock (Access is denied.)" when using Java-based functionality

Troubleshooting


Problem

User launches any java-based functionality (for example "Group - Command Center"). User receives error message.

Symptom

Error
Internal error:
[Details...] [OK]

After clicking "Details":
java.lang.RuntimeException: C:\Program Files\IBM\IBM Cognos Controller\Integration\configuration\org.eclipse.osgi\.manager\.fileTableLock (Access is denied.)
                at org.eclipse.osgi.framework.internal.core.Framework.initialize(Framework.java:192)
                at org.eclipse.osgi.framework.internal.core.Framework.<init>(Framework.java:162)
                at org.eclipse.core.runtime.adaptor.EclipseStarter.startup(EclipseStarter.java:261)
                at com.ibm.cognos.ccr.integration.IntegrationServiceAdapter.startEclipseAndServiceTracker(IntegrationServiceAdapter.java:204)
                at com.ibm.cognos.ccr.integration.IntegrationServiceAdapter.run(IntegrationServiceAdapter.java:117)
                at java.lang.Thread.run(Thread.java:736)
Caused by: java.io.FileNotFoundException: C:\Program Files\IBM\IBM Cognos Controller\Integration\configuration\org.eclipse.osgi\.manager\.fileTableLock (Access is denied.)
                at java.io.RandomAccessFile.<init>(RandomAccessFile.java:229)
                at org.eclipse.core.runtime.internal.adaptor.Locker_JavaNio.lock(Locker_JavaNio.java:33)
                at org.eclipse.osgi.storagemanager.StorageManager.lock(StorageManager.java:389)
                at org.eclipse.osgi.storagemanager.StorageManager.open(StorageManager.java:702)
                at org.eclipse.osgi.internal.baseadaptor.BaseStorage.initFileManager(BaseStorage.java:220)
                at org.eclipse.osgi.internal.baseadaptor.BaseStorage.initialize(BaseStorage.java:154)
                at org.eclipse.osgi.baseadaptor.BaseAdaptor.initializeStorage(BaseAdaptor.java:123)
                at org.eclipse.osgi.framework.internal.core.Framework.initialize(Framework.java:190)
                ... 5 more

Cause

Code production problem (APAR PM67845) which causes user to not have permission to write to the 'configuration' folder.

  • NOTE: Although read/write permission for 'configuration' will solve the error in this Technote, it is recommended that you modify the parent folder "Integration" instead, to solve the error in Technote #1600112.

Environment

User logged onto client device with a non-administrative Windows user.

Resolving The Problem

Fix:
Upgrade to Controller 10.1.1 FP1 (10.1.1671) or later.

Workaround:
On the client device, modify the NTFS permissions to the folder "Integration" to allow all users read/write access.

  • TIP: Although read/write permission for 'configuration' will solve the error in this Technote, it is recommended that you modify the parent folder "Integration" instead, to solve the error in Technote #1600112.

Steps:
  1. Logon to the client device as a Windows administrator
  2. Launch Windows Explorer
  3. Browse to the 'integration' folder. TIP: By default, this is located here: C:\Program Files\IBM\IBM Cognos Controller\Integration\
  4. Right-click on "Integration" and choose "properties"
  5. Click on "Security" tab
  6. Highlight the entry "Users"
  7. Modify the "Permissions for Users" by ticking the box 'Modify'

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.1.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21599845