Troubleshooting
Problem
IBM Case Manager (ICM) 5.1 single server installation failed with an error message DataSource Configuration: DSRA8040I: Failed to connect to the DataSource
Symptom
Running the 5.1.0-ICM-LINUX.BIN to install the ICM 5.1 on a Linux host, the error occurred when running the configCE.sh script (SCRIPT_24=configCE in cmpit.properties).
The error reported in cmpit_install.log.txt:
- Thu Mar 08 15:41:27:509 (24/37) configCE.sh
Thu Mar 08 15:41:27:515 [INFO] Processing...
Thu Mar 08 15:41:57:029 [INFO] Process completed with exit code: 1
Status: ERROR
Additional Notes: ERROR - Thu Mar 08
15:41:57:044 [ERROR] ERROR in InvokeScripts-function - Terminate the
remaining scripts.
Status: ERROR
Additional Notes: ERROR - Thu Mar 08
15:41:57:044 [ERROR] ***Aborting InvokeScripts-Install function.
....
The corresponding entries were also found in cmpit_install_stdout.txt:
- Install-InvokeDescription: (24/37) configCE.sh
invokeScript: /opt/IBM/cmpit/install-scripts/configCE.sh
Cmd: /opt/IBM/cmpit/install-scripts/configCE.sh /opt/IBM/cmpit/install-scripts /opt/IBM/cmpit/decompressed /home/admin 32 /opt/IBM/cmpit
OUTPUT>==========================================
OUTPUT>Begin configCE.sh
OUTPUT>Thu Mar 8 15:41:27 EST 2012
OUTPUT>==========================================
OUTPUT>Setting Directories...
OUTPUT>Thu Mar 8 15:41:27 EST 2012
OUTPUT>Starting to run all of the tasks in profile ConfigCE.
OUTPUT>
OUTPUT>New_Configure Object Store JDBC Data Sources ******
OUTPUT>There was an error executing the New_Configure Object Store JDBC Data Sources task.
OUTPUT>Running the task failed with the following message: The data source configuration failed:
OUTPUT>WASX7209I: Connected to process "server1" on node P8Node01 using SOAP connector; The type of process is: UnManagedProcess
OUTPUT>testing Database connection
OUTPUT>DSRA8040I: Failed to connect to the DataSource. Encountered java.sql.SQLException: [jcc][t4][2043][11550][3.62.56] Exception java.net.ConnectException: Error opening socket to server jactdftvap812/172.26.23.122 on port 3,737 with message: Connection refused. ERRORCODE=-4499, SQLSTATE=08001DSRA0010E: SQL State = 08001, Error Code = -4,499.
OUTPUT>
OUTPUT>
OUTPUT>For additional logging information, see one of the following files:
OUTPUT>
OUTPUT> <Unix> /home/<username>/configmgr_workspace/.metadata/.log
OUTPUT> <Windows> c:\Documents and Settings\Administrator\configmgr_workspace\.metadata\.log
OUTPUT>
OUTPUT>NOTE: The .log file on HPUX RISC platform is not supported.
OUTPUT>Thu Mar 8 15:41:46 EST 2012
OUTPUT>ERROR - configCE failed. Refer to /opt/IBM/cmpit/install-scripts/profiles/ConfigCE/status for more details.
Process completed with exit code: 1
ERROR in InvokeScripts-function - Terminate the remaining scripts.
***Aborting InvokeScripts-Install function.
Update: this exact issue was also presented in P8 Single-server V5.2 for (at least) Linux x86_64-CPIT_5.2_LINUX_EN.tar.gz, which did not have the setDB2port.sh either and the installation failed in exactly the same way.
Cause
The error message in cmpit_install_stdout.txt indicated that the "Failed to connect to the DataSource" was due to the error opening socket to the server on port 3737.
However, port 3737 was confirmed to be not in use.
The DB2 Control Center was launched successfully from the server and it was confirmed that the database was running on a different port, 3766.
This port problem was due to the missing setDB2port.sh script from the expected installation path as it indicated in the "cmpit_install_log.txt" file.
The error occurred earlier at running SCRIPT 10 - ConfigP8DB2, where an error was displayed: "/opt/IBM/cmpit/install-scripts/setDB2port.sh: not found".
Error message -
- Cmd: /opt/IBM/cmpit/install-scripts/configP8DB2.sh
/opt/IBM/cmpit/install-scripts /opt/IBM/cmpit/decompressed /home/admin 32 /opt/IBM/cmpit
OUTPUT>================================================
OUTPUT>Begin configP8DB2.sh
OUTPUT>Thu Mar 8 15:28:52 EST 2012
OUTPUT>================================================
...
OUTPUT>--------------------
OUTPUT>SQL1024N A database connection does not exist. SQLSTATE=08003
OUTPUT>--------------------
ERROR>-ksh: line 1: /opt/IBM/cmpit/install-scripts/setDB2port.sh: not found
OUTPUT>Thu Mar 8 15:30:59 EST 2012
OUTPUT>End configP8DB2.sh
OUTPUT>====================
Process completed with exit code: 0
...
Because the ConfigP8DB2 step (running SCRIPT_10=configP8DB2 in cmpit.properties) was not successfully completed due to the missing setDB2port.sh, it led the error occurred at the configCE step (SCRIPT_24=configCE in cmpit.properties).
Resolving The Problem
Workaround solution 1 - If there is another ICM-5.1 single server installation on Linux system available, copy the setDB2port.sh script from this host to the one with the missing script at /opt/IBM/cmpit/install-scripts.
Workaround solution 2 - Manually create a setDB2port.sh script in /opt/IBM/cmpit/install-scripts directory.
- setDB2port.sh
#!/bin/sh
#
# Licensed Materials - Property of IBM
# 5725A15, 5724R81
# (c) Copyright IBM Corp. 2010, 2011 All Rights Reserved.
# US Government Users Restricted Rights - Use, duplication or disclosure restricted by GSA ADP Schedule Contract with IBM Corp.
#
# parameter 1 = installerScriptFolder - Script folder
# parameter 2 = decompressedFolder - Destination folder to decompress files to
# parameter 3 = p8DownloadFolder - Source folder of the IBM software packages
# parameter 4 = 32 or 64 - Bitness of the OS 64 or 32 (optional)
#
echo "=========================================="
echo "Configuring DB2 Port .."
date
#su - dsrdbm01
db2 update dbm cfg using SVCENAME 3737
db2stop FORCE
db2start
db2 get dbm cfg | grep SVCENAME
exit
cd /var
echo "==========================================="
date
echo "Configured DB2 Port..."
echo "==========================================="
Was this topic helpful?
Document Information
Modified date:
17 June 2018
UID
swg21599415