IBM Support

Installation Manager - Manage Licenses Create Process error=740 from RAD v8.x on Windows 7

Troubleshooting


Problem

Attempts to apply activation kit for IBM Rational Developer Power Systems Software using IBM Installation Manager results in the error "CreateProcess error=740".

Symptom

Comments:

Screen capture above shows:
DDS Design - IBM Rational Developer for Power Systems Software perspective started, and the Manage Licenses button pressed, which starts IBM Installation Manager (IM) - Manage Licenses


Manage Licenses
- IBM Rational Developer for Power Systems software | Version: 8.5.0 |  
License Type: Permanent
-- RPG and COBOL Dev Tools for i
License Type: Trial
.....



which throws an Error Dialog:


Manage Licenses
"java.io.IOException: Cannot run the program
C:\Program Files\IBM\Installation Manager\eclipse\IBMIM.exe:  CreateProcess error=740,                                                
The requested operation requires elevation"                              
[OK]

Cause

User Authorization on Windows 7

Environment

Windows 7

Resolving The Problem

This error is typical on inadequate user authorization on Windows 7, with IBM Installation Manager (IM) and RDp or RAD or any RAD based desktop product installed under C:\Program Files... , and even if RAD is not installed under C:\Program Files... . From this point forward the document refers to the desktop product generically as RAD. There are a few ways to resolve this problem:

  1. Use IBM Installation Manager (IM) > Manage License directly instead of through RAD. This would have no problems since IM default/selects to "Run As administrator" (if installed as Admin).
  2. Start RAD: Right-click RAD icon > Run As Administrator even though the Id is part of the administrator group. This is the norm with Windows 7 and programs installed under C:\Program Files... , with its stricter security/ User account Control (UAC) settings, when full access is needed to those directories/files by an application.
    Note: Right-clicking on the RAD icon > Properties > Compatibility [Tab] has a checkbox that you can select to always Run As administrator.

    RAD typically is started using Run As Administrator, to have full access to the WebSphere Test Environment Servers and associated tooling, when RAD has been installed as an Admin Id and to have access to WAS as admin/root to mimic production environments.
  3. Avoid this situation, if appropriate, by installing the RAD product as a non-administrative user. Do this by using the "userinst.exe" version of the Installation Manager or by choosing the <check your launchpad selection> option in the launchpad when initially installing the RAD product.

Additional information:

This might be useful, but should be done with CAUTION, to set the Windows 7 UAC setting under Control Panel > User Accounts: Change User Account Control settings, to "Never notify" if you use familiar programs and visit familiar web sites:


[{"Product":{"code":"SSDV2W","label":"IBM Installation Manager"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Licensing","Platform":[{"code":"PF033","label":"Windows"}],"Version":"1.4.1;1.4.2;1.4.3;1.4.4;1.5;1.5.1;1.5.2;1.5.0.1;1.5.3","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
25 October 2021

UID

swg21599321