QCI fails to connect to HP Quality Center 11 patch 9

Technote (troubleshooting)


Problem(Abstract)

IBM Rational DOORS Quality Center Interface (QCI) 3.5.0.1 fails to connect to HP Quality Center (QC) 11 patch 9, which is the QC 11 version with the QCCR1J22427 fix required by QCI. QCI was installed successfully per the installation instructions.

Symptom

While creating a data connection for HP Quality Center 11, you get a "Data provider failed to initialize" error during the Test Connection step.


Cause

The ALM client is not registered.

Environment

This has been seen when integrating IBM Rational DOORS Quality Center Interface 3.5.0.1 with HP Quality Center 11.

Diagnosing the problem

If you are having this problem, you will not see errors in the Microsoft Windows Event Viewer or the TDIService.log file when you reproduce this problem. Most IBM Rational DOORS Quality Center Interface connection problems send errors to the Windows Event Viewer or the TDIService.log file, if not both.

Resolving the problem

To resolve this issue, please register the HP Quality Center 11 ALM client on the IBM Rational DOORS Quality Center Interface server. This procedure is documented in the Using Rational DOORS for HP Quality Center Interface Release 3.5.1 publication on pages. 65 - 66 (pp. 73 - 74 of PDF).

Cross reference information
Segment Product Component Platform Version Edition
Software Development Rational DOORS Installation Windows 3.5.0.1, 3.5.0.2, 3.5.1

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Document information


More support for:

Rational DOORS
Integrations: 3rd Party

Software version:

9.2, 9.2.0.1, 9.2.0.2, 9.2.0.3, 9.2.0.4, 9.2.0.5, 9.3, 9.3.0.1, 9.3.0.2, 9.3.0.3, 9.3.0.4, 9.3.0.5, 9.3.0.6, 9.3.0.7, 9.4, 9.4.0.1, 9.5, 9.5.0.1, 9.5.1, 9.5.1.1

Operating system(s):

Windows

Reference #:

1599182

Modified date:

2013-07-19

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