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Auditdb poor performance


Technote (troubleshooting)


Problem(Abstract)

A Tivoli Storage Manager server offline auditdb process is started but takes a long time to complete, although the database size suggests the auditdb should complete in a more timely manner.

Cause

Manual data shredding is enabled on server and data has not been shredded yet

Diagnosing the problem

The below steps may be used to determine if there is data to be shred.

  1. Verify if shredding is enabled on one or more storage pools.
    select stgpool_name,shred_count from stgpools
    A shred_count of 1 or higher indicates shredding is enabled for the storage pool.
  2. Verify if there is data to be shred
    query shredstatus f=d
    The output from the query command will show "Objects Awaiting Shred" and "Data Left To Shred (MB)"
  3. Verify the shredding server option
    q option shredding
  4. In this instance, shredding was enabled for the storage pool, shredding was set to manual and there was data left to be shredded because the "shred data" command was not run. This slowed down the auditdb process.

Resolving the problem

Follow the steps below to resolve the performance issue with the auditdb when data shredding is enabled in a disk storage pool.

  1. Start the Tivoli Storage Manager server
  2. Shred the data with the following administrator command :
    shred data
  3. Monitor how much data is left to be shredded with the following administrative command :
    query shredstatus f=d
  4. Once data is shredded, stop the Tivoli Storage Manager server.
  5. Re-run the offline auditdb process.
  6. Restart the Tivoli Storage Manager server.

Note : When running with the "shredding manual" server option, consider running the "shred data" admin command at regular interval so that data is shred regularly.

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Document information

Tivoli Storage Manager

Server


Software version:
5.5


Operating system(s):
Platform Independent


Reference #:
1598182


Modified date:
2013-05-07

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