Applying an anayltic report to an explorer diagram result in "The diagram could not be opened. The record for it was not found. Another user may have deleted the diagram.'' error in Rational System Architect

Technote (troubleshooting)


Problem(Abstract)

Attempts to apply an analytic report from the Heat Map Manager to an explorer diagram result in ''The diagram could not be opened. The record for it was not found in the encyclopedia. Another user may have deleted the diagram.'' error in IBM Rational System Architect (SA).

Symptom

You try to apply an analytic report from the Heat Map Manager to an explorer diagram, you get the following error message:


The diagram could not be opened. The record for it was not found in the encyclopedia. Another user may have deleted the diagram.


You press OK but the analytic report has not applied.

Cause

Steps to reproduce:

  1. The analytic report has a line "Current = T" in the Content field.

  2. Open an Explorer Diagram which already has the analytic report applied.

  3. Make a copy of the diagram.

  4. Save the copy with a new name.

  5. The new diagram is open in the foreground of the diagrams window.

  6. Apply the Analytic Report from the Heat Map Manager,

Diagnosing the problem

Check the content of the Analytic Report definition.

Resolving the problem

You need to remove the "Current = T" line from the analytic report content as follows:

  1. Open the definition for the Analytic Report.


  2. Look for the line in the Content field.




  3. Delete the line




  4. Press OK

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

Rational System Architect
General Information

Software version:

11.4.0.2, 11.4.0.3

Operating system(s):

Windows

Reference #:

1597832

Modified date:

2013-06-20

Translate my page

Machine Translation

Content navigation