IBM Support

eForms for P8 patch installation hangs with the message that Searching for Java(tm) Virtual Machine

Troubleshooting


Problem

eForms for P8 patch installation seems to be trying to execute the Searching for Java(tm) Virtual Machine forever every time the patch installation is attempted

Symptom

A dialog similar to the following is displayed for a very long time without any apparent progress:


Cause

A java runtime environment for the java virtual machine (JVM) required by the eForms for P8 patch is not installed on the system.

Diagnosing The Problem

  • Run the eForms for P8 patch installation from the command line with the -is:log log.txt parameter. For example, if the patch executable is P8eF-4.0.2.12-AE-WIN.exe, then run the following command at the command prompt in the same folder where the executable is located:

    P8eF-4.0.2.12-AE-WIN.exe -is:log log.txt.
  • That command will generate the log file log.txt. Open that file in a text editor.
  • The log.txt file will indicate the java runtime environments that the eForms for P8 patch installation is checking for. For example:

      Searching for Java 1.4X by Sun Microsystems using path hints
      Checking path hint C:\Program Files\Java\j2re1.4.0_01
      Verifying JVM at C:\Program Files\Java\j2re1.4.0_01\bin\java.exe
      for JVM: Java 1.4X by Sun Microsystems
      C:\Program Files\Java\j2re1.4.0_01\bin\java.exe does not exist

Resolving The Problem

Install a java runtime environment that the eForms for P8 patch installation is looking for.

[{"Product":{"code":"SSTHRT","label":"IBM Case Foundation"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"eForms for P8","Platform":[{"code":"PF033","label":"Windows"}],"Version":"4.0.2","Edition":"All Editions","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21597789