Remove backup to TSM fails ANS1245E (RC122)

Technote (troubleshooting)


Problem(Abstract)

sbtsmlist -r fails ANS1245E (RC122)

Symptom

Backups fail BMR0041E backup already in progress. When trying to remove the backup with:

      sbtsmlist -r
    It fails with error:
      ANS1245E (RC122) The file has an unknown format

Cause

TSM Client API return code 122 is: 0122 E: DSM_RC_UNKNOWN_FORMAT The file has an unknown format.

A common cause is TSM Client API version is downlevel from the API version used to start the backup.


Resolving the problem

Upgrade TSM Client and API to a later version.

For example, in one case customer had upgraded sysback from 6.1.2 to 6.1.3 and TSM API from 5.5.0.0 to 5.5.4.0. They were able to successfully remove the backup to TSM by upgrading TSM client to 6.2.4.

TSM client is available at the FTP site here:
ftp://service.software.ibm.com/storage/tivoli-storage-management/maintenance/client/

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Document information


More support for:

Tivoli Storage Manager for System Backup and Recovery

Software version:

6.1.2.0, 6.1.3.0

Operating system(s):

AIX

Software edition:

Edition Independent

Reference #:

1597431

Modified date:

2014-04-30

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