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Unable to install an Information Server patch on Windows Client


Technote (troubleshooting)


Problem(Abstract)

when running the patch installer you get the error message
"com.ibm.is.install.exception.InvalidSuiteModelException: CDIIN4237E:"h

Cause

"Suite model could not be built" normally means that the installer's stored information about what's installed is corrupted in the InformationServer/_uninstall directory. There is a mismatch between the _uninstall/suite.jar file and the array of InstallSpec.xml files in the directories under _uninstall/payloads.

Diagnosing the problem

In some cases an incorrect version of an updater has been applied, for example an 8.5.0.290 update installer has been applied to IS 8.7.

Resolving the problem

Two possible solutions
When updateImage updates the _uninstall directory, it creates a backup of all the files it replaced. That backup is called _uninstall/Backup_<timestamp>. You should go back to the earlier backup and copy its entire contents into _uninstall. That should restore the _uninstall to the state it had right after the original suite install. Then proceed as usual.

The other solution is to uninstall and reinstall.

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IBM, the IBM logo and ibm.com are trademarks of International Business Machines Corp., registered in many jurisdictions worldwide. Other product and service names might be trademarks of IBM or other companies. A current list of IBM trademarks is available on the Web at "Copyright and trademark information" at www.ibm.com/legal/copytrade.shtml.

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Document information

InfoSphere DataStage


Software version:
8.5, 8.7


Operating system(s):
Windows


Reference #:
1596922


Modified date:
2012-11-18

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