IBM Support

InfoSphere DataStage : disconnected dsapi_slave processes on the engine tier

Troubleshooting


Problem

Disconnected or orphaned InfoSphere DataStage dsapi_slave processes might be left running on systems where the InfoSphere Information Server engine tier is installed. In general disconnected dsapi_slave processes are not a major issue. But follow these instructions when several orphaned processes cause degradation in system performance, or cause problems administering the system.

Cause

A dsapi_slave process is required for communication between an InfoSphere DataStage client and the engine tier. For example, clients such as Designer, Director, Administrator, and DSJob command connect to the engine tier to design and control jobs.

If the client is unexpectedly terminated during a period of inactivity, it is possible for the dsapi_slave to become orphaned. If the current connection inactivity time out is set to "Do not timeout," the process does not terminate until the machine is rebooted. If an inactivity time out is specified: the process terminates after the time out period.

Note. Normal client program termination does not result in orphaned dsapi_slave processes.

Environment

The dsapi_slave processes run only on the engine tier.

Diagnosing The Problem


There should not be any dsapi_slave processes running if there are no clients connected. Otherwise, the number of dsapi_slave processes should roughly correspond to the number of clients.

On Linux/UNIX based operating systems:

    Run "ps -ef | grep dsapi_slave" to determine the number of processes

On Microsoft Windows operating systems:
    Use the "Processes" tab of the Window's Task Manager to manually count the number of processes that have an image name: dsapi_slave.exe.

Some clients are capable of using more than one connection and therefore more than one dsapi_slave process can be associated to a client.

Resolving The Problem

The dsapi_slave processes can be stopped using the "kill" command on Linux/UNIX based systems or by using the Task Manager "End Process" button on Microsoft Windows systems.

To prevent this issue, you can set an inactivity time out for all connections. Use the InfoSphere Information Server Administrator client to configure connections:


    On the Administrator client "General" tab, uncheck "Do not timeout", and set the "Inactivity timeout" value to an appropriate number of seconds for your environment.

    Note. As the name suggests, if a DataStage client application is left inactive for the specified inactivity time out period, the client connection is terminated and the corresponding dsapi_slave process ends.

    Subsequent attempts to use the client application results in connection errors being displayed. You can no longer use the client. Any work that has not been saved is lost.

    In order use the client application, close it in the normal fashion and ignore any errors. Proceed by running it again.

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Document Information

Modified date:
16 June 2018

UID

swg21596423