IBM Support

CTGWA4016E "HTTP Response code: 505" errors on import using tipcli

Troubleshooting


Problem

The tipcli.log contains the following error after importing using the Tivoli Integrated Portal tipcli utility: SEVERE: Exception:CTGWA4016E Command failed. HTTP Response code: 505

Cause

The error occurs when the import scripts detect a lock on files in the target system.

Diagnosing The Problem

Review the tipcli.log for the following errors:

#######
Jun 1, 2012 3:01:10 AM com.ibm.tivoli.tip.cli.HTTPHelper makeConnection


INFO: URL=https://localhost:16311/ISCHA/NotificationServlet?username=tipadmin&pas…

#######



#######


Jun 1, 2012 3:01:28 AM com.ibm.tivoli.tip.plugin.HAImportPlugin SendURL
SEVERE: Exception:CTGWA4016E Command failed. HTTP Response code: 505.
Throwable occurred: java.lang.Exception: CTGWA4016E Command failed. HTTP Response code: 505.
at com.ibm.tivoli.tip.cli.TIPCLI.makeException(TIPCLI.java:138)
at com.ibm.tivoli.tip.cli.HTTPHelper.checkHTTPReturnCode(HTTPHelper.java:96)
at com.ibm.tivoli.tip.cli.HTTPHelper.makeConnection(HTTPHelper.java:134)
at com.ibm.tivoli.tip.plugin.HAImportPlugin.sendURL(HAImportPlugin.java:305)
at com.ibm.tivoli.tip.plugin.HAImportPlugin.unlockSystem(HAImportPlugin.java:235)
at com.ibm.tivoli.tip.plugin.HAImportPlugin.migrate(HAImportPlugin.java:181)
at com.ibm.tivoli.nc.migration.MigrationController.migrate(MigrationController.java:526)
at com.ibm.tivoli.nc.migration.MigrationController.performMigration(MigrationController.java:317)
at com.ibm.tivoli.nc.migration.MigrationController.performMigration(MigrationController.java:288)
at com.ibm.tivoli.tip.cli.ei.PageImportCommand.invokeMigrationTool(PageImportCommand.java:355)
at com.ibm.tivoli.tip.cli.ei.PageImportCommand.run(PageImportCommand.java:320)
at com.ibm.tivoli.tip.cli.TIPCLI.doIt(TIPCLI.java:61)
at com.ibm.tivoli.tip.cli.TIPCLI.main(TIPCLI.java:224)

Jun 1, 2012 3:01:28 AM com.ibm.tivoli.tip.cli.HTTPHelper makeConnection
INFO: URL=https://localhost:16311/ISCHA/NotificationServlet?username=tipadmin&pas…

#######

Resolving The Problem

No action is required. The error can be ignored.

The import utility locks all configuration files to ensure that no changes are done to the configurations while the import is running. After the import completes it attempts to unlock the files. If the number of files is too large the HTTP 505 error is returned. However, a subsequent generic command is executed to complete the unlock task for all files

[{"Product":{"code":"SSRLR8","label":"Tivoli Components"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"--","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"1.1.1;2.1;2.2","Edition":"","Line of Business":{"code":"","label":""}}]

Document Information

Modified date:
17 June 2018

UID

swg21596367