Skip to main content

Business Space incorrectly parses the Common Name (CN) attribute if it contains the '\' character


Technote (troubleshooting)


Problem(Abstract)

A '\' character in the Common Name (CN) attribute causes Business Space to parse the Common Name incorrectly.

Symptom

The error messages BMWMB0080E & SECJ0369E appear in your log file.


Cause

This issue is caused by a comma in the CN. The '\' character is an escape character used to escape the comma. This causes issues in the code consumed by the mashups.

This has been identified as a product defect under APAR LO69472.


Environment

Business Space 7.0.x

Resolving the problem

IBM has created a patch to fix this problem on WebSphere Business Monitor V7.0.x. Details on installing patches can be found here:

http://www.lotus.com/ldd/mashupswiki.nsf/dx/Installing_Patches_from_IBM_Support

com.ibm.mm.framework.rest.next_2.0.0.20120518-1216.jarcom.ibm.mm.framework.rest.next_2.0.0.20120518-1216.jar

Later versions of Business Space, such as 7.5 are not subject to this problem.


Related information

A simplified Chinese translation is available

Rate this page:

(0 users)Average rating

Copyright and trademark information

IBM, the IBM logo and ibm.com are trademarks of International Business Machines Corp., registered in many jurisdictions worldwide. Other product and service names might be trademarks of IBM or other companies. A current list of IBM trademarks is available on the Web at "Copyright and trademark information" at www.ibm.com/legal/copytrade.shtml.

Rate this page:


(0 users)Average rating

Add comments

Document information

WebSphere Business Monitor

Business Space


Software version:
7.0, 7.0.0.2, 7.0.0.3, 7.0.0.4


Operating system(s):
AIX, HP-UX, Linux, Linux zSeries, Mobile OS, Solaris, Windows, z/OS


Reference #:
1596257


Modified date:
2012-11-13

Translate my page

Content navigation