IBM Support

A Linux client update fails with "A file error occurred while using an external tool" in Rational Synergy

Troubleshooting


Problem

Attempts to update a Linux client result in "A file error occurred while using an external tool" when using IBM Rational Synergy.

Symptom

When you start a Rational Synergy client it verifies that the client version matches the server version.

If they do not match, you cannot update the client.

If you try this on a Linux client it will fail with an error similar to the following:


IBM Rational Synergy
A file error occurred while using an external tool.
Error: A file error occurred while using an external tool: /tmp/update8711309321464254480.tmp/Update_7.2-0.2.001.exe
Execute the tool from a command prompt, or provide the complete path to the tool.

For more details check the log files stored at
/home/server/ccmlog

Cause

Windows clients have the automatic deployment tool. When the developer/java client startup detects that the client version is different to the server, it can automatically download and install the
client patches.

The automated deployment tool for Rational Synergy clients is only designed to work for Windows clients is was never intended to work on UNIX or Linux clients.

The installation model for UNIX and Linux is to have a central server with all the executables installed on it. These executables are then mounted onto the client machines you wish to use. In this way you only have to update one installation when you upgrade. It is possible to have a Solaris server and also the executables for Linux on the same server.

Note: Solaris clients would then point CCM_HOME to the Solaris executables and Linux clients would point CCM_HOME to the Linux executables. This can be automatically achieved on UNIX/Linux platforms using an automounter.

Resolving The Problem

There is currently no resolution for this issue in Rational Synergy.

Enhancement request RATLC02582330 has been submitted for this functionality but has been rejected by product management. You may still comment on this suggestion.

WORKAROUND:

This does not answer the automatic deployment problem but provides a single update package for you to deploy.

  1. Take a copy of the installation in $CCM_HOME on the server
  2. Remove files that are not needed for a client installation (Informix, databases, old patches...)
  3. Pack the copy as a Debian package
  4. Install on the client machines.

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Document Information

Modified date:
22 December 2020

UID

swg21595653