IBM Support

Business Space v7.5.1 iFix 2 disables SSL redirect, causes Case Builder solution deploy to fail

Troubleshooting


Problem

For a Case Manager V5.1 installation with Single Sign-On (SSO), installing Business Space 7.5.1 iFix 2 disables SSL redirection, which causes solution deployment from Case Builder to fail.

Symptom

After Business Space 7.5.1 iFix 2 is installed, Case Builder solutions deployments fail.

Cause

The installation of Business Space 7.5.1 iFix 2 makes SSL redirection unavailable. When the SSL redirection does not occur, the Case Manager API fails to connect to Business Space. This connection failure causes solution deployment in Case Builder to fail.

Resolving The Problem

Use the instructions indicated in the following IBM Business Process Manager Info Center documentation to enable SSL redirection:

http://www.ibm.com/support/knowledgecenter/SSWLGF_7.5.0/com.ibm.bspace.imuc.doc/topics/tcfg_bsp_sec_https.html

Including a snapshot of the page in case the link no longer works.

IBM Knowledge Center - Designating HTTP or HTTPS settings for Business Space.pdfIBM Knowledge Center - Designating HTTP or HTTPS settings for Business Space.pdf

In the preceding instructions, follow option 3.b. for IBM Case Manager HTTP to HTTPS redirection for SSL connections to Business Space, which is the default setting.

[{"Product":{"code":"SSCTJ4","label":"IBM Case Manager"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Not Applicable","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"},{"code":"PF027","label":"Solaris"}],"Version":"5.1.0.0;5.1.0.1","Edition":"All Editions","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21595619