Enterprise Content Manager Toolkit for z/OS install issues.

Technote (troubleshooting)


Problem(Abstract)

While installing the z/OS toolkit and eClient on z/OS under USS, we encountered several problems. We ran ICMECCFG and it created a configEC.properties file with missing first characters. There was also a path issue related to the cmblogconfig.properties file and a number of other issues.

Symptom

The configEC.properties file created after running ICMECCFG is truncating the first character in a number of lines causing build issues. Also, there was a not found on the cmblogconfig.properties file.


Cause

The cause of the first problem is a bad RECFM of FBA instead of FB. The second problem is caused by not having write authority to the cmblogconfig.properties file.

Environment

z/OS

Diagnosing the problem

You receive the following error message in the ECCFG2 step when running the ICMECCFG job:


BUILD FAILED
/SERVICE/ICM/V843/TOOLKIT/TLKTFP1/config/eclient/configEC.xml:65: The
following error occurred while executing this line:
/SERVICE/ICM/V843/TOOLKIT/TLKTFP1/config/eclient/configEC.xml:84: The
following error occurred while executing this line:
/SERVICE/ICM/V843/TOOLKIT/TLKTFP1/config/eclient/websphere.xml:89: Could
not read filters from file /SERVICE/ICM/V843/TOOLKIT/TLKTF
P1/config/eclient/Name of the temp directory/was.properties as it
doesn't exist.

For the second error, you see path errors in the dklog.


Resolving the problem

To fix the truncation issue, change the RECFM to FB. To fix the second run the following command to allow write authority: chmod og+w cmblogconfig.properties. Then restart the eClient.

Rate this page:

(0 users)Average rating

Document information


More support for:

Content Manager for z/OS
Other

Software version:

8.4, 8.4.0.1, 8.4.1, 8.4.1.1, 8.4.2, 8.4.2.1, 8.4.2.2, 8.4.2.3, 8.4.3, 8.4.3.1

Operating system(s):

z/OS

Software edition:

All Editions

Reference #:

1595538

Modified date:

2012-05-29

Translate my page

Machine Translation

Content navigation