Launch of Rational PurifyPlus on Windows 7 results in license error

Technote (troubleshooting)


Problem(Abstract)

Attempts to launch IBM Rational PurifyPlus on Microsoft Windows 7 result in the error "Failed to check out a key".

Symptom

Rational PurifyPlus for Windows Authorized User license key has been imported, but Rational Purify (PureCoverage, Quantify) can not be launched due to the license error:

Failed to check out a key for PurifyPlus
FLEXlm error -2, Invalid license file syntax OR no license in file.
FLEXlm error -15, Cannot connect to license server.

Cause

This issue may happen when Rational PurifyPlus for Windows Authorized User license key is imported on Windows 7 without Administrator authority, in which case the license is not written into the correct license file.

Resolving the problem

There are two workarounds to solve the issue.

WORKAROUND 1

  1. Log in to Windows 7 as Administrator
    Note: You must be logged in as the "Administrator" user itself, not any other user in the Administrators group.
  2. Import the Rational PurifyPlus license key (double click the license key file)


WORKAROUND 2
  1. Log in to Windows 7 as any other user
  2. Right click IBM Rational License Key Administrator and click Run as administrator
  3. Click Menu > License Keys > Import License Key(s)...
  4. Navigate to the license key file
  5. Import

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

Rational PurifyPlus
Licensing

Software version:

7.0.1

Operating system(s):

Windows

Reference #:

1595509

Modified date:

2012-05-23

Translate my page

Machine Translation

Content navigation