Troubleshooting
Problem
Unable to send data in Gentran:Director. Communications log reports an error: Unable to connect to host. RC = -10051 GenMail exiting SendEDIMessage with RC = -10051 OR Unable to connect to host. RC = -10060 GenMail exiting SendEDIMessage with RC = -10060
Symptom
Communication log failure, error reported when doing a send session in Gentran Director
Opening SMTP session on port 25 with host primary.ca.globalec.com.
Host responds:
Unable to connect to host. RC = -10051.
Connecting to secondary SMTP server secondary.ca.globalec.com.
Preparing to send message.
Loading message file C:\Program Files\COMMERCE Connection32\CEMail\Outbox\out71AA.tmp.
Opening SMTP session on port 25 with host secondary.ca.globalec.com.
Host responds:
Unable to connect to host. RC = -10051.
GenMail exiting SendEDIMessage with RC = -10051
OR
Opening SMTP session on port 25 with host primary.ca.globalec.com.
Host responds:
Unable to connect to host. RC = -10060.
Connecting to secondary SMTP server secondary.ca.globalec.com.
Preparing to send message.
Loading message file C:\Program Files\COMMERCE Connection32\CEMail\Outbox\out71AA.tmp.
Opening SMTP session on port 25 with host secondary.ca.globalec.com.
Host responds:
Unable to connect to host. RC = -10060.
GenMail exiting SendEDIMessage with RC = -10060
Cause
This is a network related error often related to the firewall. Please consult a network administrator to open port 25 so that Gentran can send data to a Sterling Commerce/IBM mailbox.
Diagnosing The Problem
Telnet test to make sure the port is open and not blocked
Go to Start, Command, Run |
Gentran:Director uses SMTP ports 25 or 2375, so you can telnet for both ports, which are used for sending data. You can also telnet POP3 port 110 used for receiving data, and usually is not blocked, which is the reason data can be received.
Resolving The Problem
Please consult a network administrator to open port 25 so that Gentran can send data to a Sterling Commerce/IBM mailbox. Or contact your Internet Service Provider (ISP) to ask them to unblock the port needed. Sometimes ISP's will block these ports.
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Document Information
Modified date:
16 June 2018
UID
swg21595421