Unable to connect to host. RC = -10051

Technote (troubleshooting)


Problem(Abstract)

Unable to send data in Gentran:Director. Communications log reports an error: Unable to connect to host. RC = -10051 GenMail exiting SendEDIMessage with RC = -10051

Symptom

Communication log failure, error reported when doing a send session in Gentran Director
Opening SMTP session on port 25 with host primary.ca.globalec.com.
Host responds:
Unable to connect to host. RC = -10051.
Connecting to secondary SMTP server secondary.ca.globalec.com.
Preparing to send message.
Loading message file C:\Program Files\COMMERCE Connection32\CEMail\Outbox\out71AA.tmp.
Opening SMTP session on port 25 with host secondary.ca.globalec.com.
Host responds:
Unable to connect to host. RC = -10051.
GenMail exiting SendEDIMessage with RC = -10051


Cause

This is a network related error often related to the firewall. Please consult a network administrator to open port 25 so that Gentran can send data to a Sterling Commerce/IBM mailbox.

Diagnosing the problem

In Gentran go to Tools>Communications>Log. Open a log which indicates a failure. Review the log for the applicable error message.

Resolving the problem

Please consult a network administrator to open port 25 so that Gentran can send data to a Sterling Commerce/IBM mailbox.

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Document information


More support for:

Sterling Gentran:Director

Software version:

5.3.1, 5.4, 5.5

Operating system(s):

Windows

Software edition:

All Editions

Reference #:

1595421

Modified date:

2012-08-06

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