IBM Support

DataStage job takes a long time to startup.

Troubleshooting


Problem

DataStage Job startup times sometimes takes minutes when using IBM InfoSphere Information Server.

Symptom

The log shows that a lot of time (minutes) being taken from job initial start to showing the environment variables. However this time is not showing up in the job startup time at the end of the job log for a run.

Cause

The $TEMP environment variable points to /tmp by default. If /tmp has a lot of files or is full, it will cause DataStage jobs to take longer to startup. The number of files in /tmp causes the issue as DataStage uses this directory as a hashed file.

Resolving The Problem

You can either clean up /tmp to reduce the number of files or you can set $TEMP environment variable in the Projects to point to an empty filesystem.

[{"Product":{"code":"SSZJPZ","label":"IBM InfoSphere Information Server"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"}],"Version":"8.5;8.7;8.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
16 June 2018

UID

swg21595254