IBM Support

Launchpad does not open on AIX or Linux operating systems for the IBM Business Process Manager (BPM) 7.5.x and IBM Business Monitor V7.5.x products

Troubleshooting


Problem

When you try to install using the Launchpad, the Launchpad does not open. Instead, a supported browser error message is shown.

Symptom

The error message contains the following text:

Unable to find supported browser
The launchpad cannot start. This error typically occurs when a supported browser cannot be found.

Cause

When Firefox has been updated to Version 10 or later, the Launchpad cannot identify it as having been installed.

Diagnosing The Problem

Use the firefox -version command to determine the exact version of Firefox that you have installed.

Resolving The Problem

To get the Launchpad working in older versions, you need to edit the <install_root>/launchpad/browser.sh command so that it contains the following string in the supportedFirefoxVersion case statement:

*Firefox\ [1-9][0-9].*) return 0;;

The function should then look like this:

supportedFirefoxVersion()
{
       case "$*" in
               *Firefox\ [1-9].*) return 0;;
               *Firefox/[1-9].*) return 0;;
               
*Firefox\ [1-9][0-9].*) return 0;;
 ...

As an alternative, you can upgrade to the IBM Business Process Manager and IBM Business Monitor Version 8.0 or higher products, which do not have this issue.

If you continue to experience this issue with a higher version, refer to the technote in the Related URL section below.

[{"Product":{"code":"SSFTN5","label":"IBM Business Process Manager Advanced"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Installation \/ Configuration","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"}],"Version":"7.5.1;7.5.0.1;7.5","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}},{"Product":{"code":"SSFTDH","label":"IBM Business Process Manager Standard"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Installation \/ Configuration","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"}],"Version":"7.5.1;7.5.0.1;7.5","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}},{"Product":{"code":"SSFTBX","label":"IBM Business Process Manager Express"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Installation \/ Configuration","Platform":[{"code":"PF016","label":"Linux"}],"Version":"7.5.1;7.5.0.1;7.5","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}},{"Product":{"code":"SS7NQD","label":"IBM Business Monitor"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"General","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"}],"Version":"7.5.1;7.5.0.1;7.5","Edition":"","Line of Business":{"code":"LOB36","label":"IBM Automation"}}]

Document Information

Modified date:
15 June 2018

UID

swg21595098