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Calls to softphone from newer Cisco handsets fail


Technote (troubleshooting)


Problem

Attempts to make calls to the softphone from newer Cisco handsets result in failed calls when using IBM Sametime Unified Telephony.

Symptom

Once you configure CUCM 7 and try making calls with a 7970 Cisco IP
Phone to an SUT softphone, calls will fail.


Cause

This has been identified as a product defect under APAR LO68911

Environment

Sametime Unified Telephony 8.5.1.1

Diagnosing the problem

The 7970 Cisco IP Phone and many newer Cisco IP Phones support the G.
722 codec. There is a setting in CUCM 7 which allows the use of this
codec to be turned off (thus the workaround). When it is turned off
things work fine, however when the G.722 codec is allowed/enabled (the default in
CUCM 7) then the calls to the softphone fail

When pre-condition signalling is enabled on the Telephony Control Server and CUCM sets a=sendonly with G.722 codec, the Telephony Control Server responds with a=recvonly with G.722 and CUCM thinks that G.722 has been negotiated. However, neither the Media Server nor the softphone actually support G.722 (a=rtpmap:9 G722/8000, the softphone does support the similar sounding but fundamentally different G.722.1 in the form of a=rtpmap:108-110 G7221/16000 bitrates 16000-
32000) so when CUCM tells Telephony Control Server that this was negotiated, the Media Server
and softphone end up negotiating just RFC2833 (4733) DTMF and nothing
else, so the call fails.


Resolving the problem

The 7970 Cisco IP Phone and many newer Cisco IP Phones support the G.722 codec.
There is a setting in CUCM 7 which allows the use of this
codec to be turned off (thus the workaround). When it is turned off
things work fine.


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Document information

IBM Sametime Unified Telephony

Making Calls


Software version:
8.5.1.1


Operating system(s):
Linux, Mac OS X, Windows


Reference #:
1594715


Modified date:
2012-05-22

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