IBM Support

"Controller Link" toolbar icon and Excel-based functionality (e.g. "Company - Data Entry") does not work in CCR.EXE if user's password is set to expire

Troubleshooting


Problem

User launches Controller. User is promoted to change their password, but declines ('No'). User then is presented with the main Controller client screen. User tries to use the Excel-based functionality (e.g. "Company - Data Entry - Reported Values") but either Excel does not launch, or the user finds that they are not logged onto Controller (inside that Excel link session). User may also see the message 'The user is not active'.

Symptom

When the user launches Controller, they are presented with the following question:

    Warning
    Your password will expire in 1 days. Do you want to change the password ?
    [Yes] [No]


If the user clicks 'No' they can load the main Controller client (CCR.EXE) successfully. However, if they try to launch and Excel-based functionality from within the main Controller client, they find that it fails.

If Excel does open, the user finds that they are not logged onto Controller (inside the Excel-link):


2. If a user's password is already expired get the message 'The user is not
active'. If a password is set to expire in 30 days , the user may not log in before it expires. Same workarounds below are valid for this issue. Additionally ADM user will need to make the User active.

Cause

Defect (APAR reference PM66496) in Controller, which is triggered when the user's password is set to expire soon (e.g. in less than 10 day's time).

Environment

Both of the following are true:

  • The Controller system is configured to use 'Native' security (not Cognos / CAM security, for example 'Active Directory')
  • The user belongs to a user group which is configured for the password to expire after a certain number of days, for example:

Resolving The Problem

Fix:

The fix depends on the version of Controller that you are currently using:

  • Controller 10.1.391 or earlier: Upgrade to Controller 10.1.394.
  • Controller 10.1.1305 or later: Upgrade to Controller 10.1.1 FP1 (10.1.1671) or later.

Workarounds:

Either:

(1) Use Cognos (CAM) Security (not 'Native')

(2) Modify the users so that their password does not expire, by doing the following:

  1. Click "Maintain - Rights - Users"
  2. Select the user group that the 'bad' user(s) belong to
  3. Locate the section "Password Settings"
  4. Inside "Expires After:" delete the entry (so the password no longer expires).

or (3) (Recommended) The 'bad' end user must change their password when prompted by the 'main' Controller application (not ignore the message).


    Steps for (3):
    1. Exit Controller/Excel
    2. Launch main Controller client
    3. When asked, choose 'Yes' to change password.

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.1;10.1.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21593982