IBM Support

Unable to start TM1 Perspectives after installing Microsoft Security Update(s)

Troubleshooting


Problem

After installing the Microsoft Security patches, TM1 Perspectives failed to start with Microsoft Error message.

Symptom

Could see any or all of the following Microsoft Errors Messages :
Object library invalid or contains references to object definitions that could not be found

Could not load an object because it is not available on this machine

Compile error in hidden module: MenuFuncs

Microsoft Visual Basic
Automation error
Unspecified error

Cause

Installing one of the Microsoft security patches below (could be others as well):

http://support.microsoft.com/kb/2671605
MS12-025: Vulnerabilities in the .NET Framework could allow remote code execution

http://support.microsoft.com/kb/2664258
MS12-027: Vulnerability in MSCOMCTL.OCX could allow Remote Code Execution

http://support.microsoft.com/kb/2639185
MS12-028: Vulnerability in Microsoft Office could allow for remote code execution

http://support.microsoft.com/kb/2687323
MS12-060: Description of the security update for Office 2003 and Office 2003 Web Components

Environment

Windows

Diagnosing The Problem

Sometimes Microsoft Shared Libraries (DLLs) and ActiveX Controls (OCXs) like MSCOMCTL.OCX can become corrupt/unregistered when installing or uninstalling software.

Resolving The Problem

Unregister and re-register the mscomctl.ocx file.

1. Click Start, type cmd.
2. Right-click the cmd icon, and then click Run as Administrator.
3. Depending on your operating system, type the either of the following commands, and then press Enter:

  • For 64-bit operating systems, type the following:
    Regsvr32 /u "C:\Windows\SysWOW64\MSCOMCTL.OCX"
    Regsvr32 "C:\Windows\SysWOW64\MSCOMCTL.OCX"
  • For 32-bit operating systems, type the following:
    Regsvr32 /u "C:\Windows\System32\MSCOMCTL.OCX"
    Regsvr32 "C:\Windows\System32\MSCOMCTL.OCX"

Once the file has successfully re-registered, start Perspectives to confirm whether this has resolved the problem.

If the problem is not resolved, the mscomctl.ocx could be either corrupted or an old version (earlier than May 02, 2012). In this case, copy the mscomctl.ocx file from a machine which does not throw this error or download the latest version to microsoft and then register the file as directed above.

[{"Product":{"code":"SS9RXT","label":"Cognos TM1"},"Business Unit":{"code":"BU053","label":"Cloud \u0026 Data Platform"},"Component":"TM1 Perspectives","Platform":[{"code":"PF033","label":"Windows"}],"Version":"9.5.1","Edition":"All Editions","Line of Business":{"code":"LOB10","label":"Data and AI"}},{"Product":{"code":"SSDL22","label":"IBM Planning Analytics Express"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":" ","Platform":[{"code":"","label":""}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
10 November 2022

UID

swg21593238