IBM Support

The CAC hangs when trying to create an "Execute Analyst Macro" step

Question & Answer


Question

In the Contributor Administration Console (CAC), when trying to add a macro step "Execute Analyst Macro" in a macro, after having clicked on the ellipsis button to display the list of available Analyst macros, the CAC gets frozen and is not responding anymore. There is an error in the PlanningErrorLog.csv file : Component : AFWWrapper_10 Unable to call 'Init' on the Analyst engine. Automation error The remote procedure call failed.

Cause

Contributor is unable to launch the underlying Analyst instance (dyalog32.exe)

Answer

1) On the Planning Server machine, open the Properties of the "IBM Cognos 10 Planning" service, go to the "Log On" tab, and take a look at the account that is running this service (if this is Local System then this has to be changed to a named user).
Open a Windows session on that server as this same account, and verify wether the Planning Analyst user interface can be run, and that an object from one library can be opened.

2) Close all Planning administration tools, verify there is no user currently accessing any of the Analyst libraries, verify there is no dyalog32.exe process in Windows Task Manager. Then open FileSys.ini from /ibm/cognos/c10/bin directory and verify there is no line starting with "InstanceLock", for example :
InstanceLock={F4A3BA0A-17C3-4627-BBF7-F47090028BD0}
If there is such a line, then delete it and save the FileSys.ini.
Restart the CAC and retry to create an Execute Analyst Macro step.

3) Close all Planning administration tools, verify there is no user currently accessing any of the Analyst libraries, verify there is no dyalog32.exe process in Windows Task Manager. Then open FileSys.ini from /ibm/cognos/c10/bin directory and take a look at the syntax of the directories (path to libraries, to Locks.log, to Logins.log, and to TAB files). Try different notations :
- If using an UNC with administrative share (with dollar sign, like \\ServerName\Share$) then try a non-administrative share.

4) Make sure the user account running the 2 IBM Cognos OS services has full control over the EP install folders. Being a member of the OS Administration Group doesn't always allow enough access to fully run EP.
- If none of the UNC notations work, then try to map the network share to a drive letter (like H:\...) and make sure that the users running IBM Cognos 10 Planning service and the CAC have access to it.

[{"Product":{"code":"SSPN2D","label":"Cognos Planning"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Contributor","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.1;10.1.1","Edition":"All Editions","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21593072