IBM Support

Unable to login to TM1 Server when TM1 Admin Server has multiple network adapters (NICs)

Troubleshooting


Problem

Attempts to connect to TM1 Server are unsuccessful and "blocked" when TM1 Admin Server machine has multiple network adapters (NICs)

Symptom

Attempts to login to the TM1 Server from a client (e.g. TM1 Perspectives or TM1 Architect) installed on the same machine where TM1 Admin Server and TM1 Servers are running are successful.

Attempts to login to the TM1 Server from a client (e.g. TM1 Perspectives or TM1 Architect) installed on a machine OTHER THAN the machine where TM1 Admin Server and TM1 Servers are running are NOT successful and seem to "hang" . TM1 Architect will not display the login form when user attempts to connect to a TM1 Server. TM1 Perspectives will exhibit similar behavior when attempting to login using the Server Explorer. If using the "Connect" button in Excel (with TM1 Perspectives Add-In loaded), the TM1 server can be selected, but then the login form fields (username and password) are grayed out.

When attempting to login to TM1Web...

- when selecting the AdminHost / TM1 Admin Server, and the list of TM1 Servers populate to select, only ONE TM1 Server is listed (even though there may be several others registered with the selected AdminHost).

- the TM1 Server can be selected and login credentials entered, however once done, the Login button becomes grayed out / unavailable.

Based on error messages either displayed to user, or captured in the logfiles, connections appear to be trying to connect to BOTH NICs / IP Addresses for the machine where the TM1AdminServer is running.

Cause

TM1 components not completely configured to work in a machine with Multiple Network Adapters (NICs).
The order of the network binding connections in Windows (on the machine hosting TM1 Admin Server) may not be optimized.

Environment

Machine where TM1 Admin Server (and TM1 Servers) are running has multiple network adapters (NICs) and each is configured with its own IP address.

NOTE: this issue seems to be more prevalent when a storage area network (SAN) is used and one or more components of the system are stored within the SAN.

Diagnosing The Problem

Try disabling the 2nd NIC as a test (to see if this resolves the problem).

If the TM1 Admin Server is run as a desktop application instead of a service, the IP address that the TM1 Admin Server will be displayed in the window, and is binding to the wrong IP address / NIC.

Resolving The Problem

First, make sure you have specified the IPAddress parameter in the tm1s.cfg file(s) for the TM1 Server(s).

Reference the documentation for more details on this parameter. In this case with multiple NIC cards, use this parameter to specify the IP Address of the TM1Server in order to effectively "link" the TM1 Admin Server and TM1Server(s) running on the same machine to the designated correct IP address.

This should resolve the problems with the installed TM1 Clients such as TM1 Architect and TM1 Perspectives, and should also be done as part of resolving problems for TM1Web.

Testing TM1Web at this point may display some errors in the tm1web.log similar to the following (and the error is displaying the INCORRECT IP address):

ERROR Applix.TM1.API.Internal._TM1Main - Failed attempt to connect to host [ServerName] on port [5498] with SSLCertID [tm1adminserver] Message [TM1APIDOTNET Exception: - System.Net.Sockets.SocketException: No connection could be made because the target machine actively refused it ##.##.##.##:5498]

Update the web.config file for TM1Web with the correct IP address for the "AdminHostName" key:


<!-- If set, users will not be asked to enter Admin Host during login. -->
<add key="AdminHostName" value="##.##.##.###" />

Review the order of your network binding connections within the OS settings.
This can be found in Windows Server 2008 by navigating to the Control Panel->Network and Sharing Center->left side, select Change Adapter Settings.

Press the ALT key on your keyboard, to make the File Menus appear, and select Advanced, then Advanced Settings. In the top window, move the "IP for TM1" to the top of the list. Restart the server machine (or at least restart all the TM1 Services - EXCEPT for the TM1 Admin Server service), and then try starting the TM1 Admin Server as a desktop application again, and see what IP address is registered and that the TM1 Admin Server is using.

If it now binds to the correct IP Address, then test TM1Web and confirm whether this resolved the problem.

If the machine does not have multiple NIC cards, also see technote 1456587 (link below).

Related Information

[{"Product":{"code":"SS9RXT","label":"Cognos TM1"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"TM1","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.1.0;10.1.1;10.2;10.2.2","Edition":"All Editions","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21592968