Pivot tables generated from Statistics 20 always show “Processing” in Statistics 19.0 and is never displayed.

Technote (troubleshooting)


Problem(Abstract)


On Windows and Mac operating systems if you create an output which contains pivot tables in Statistics 20 and then open the output file in SPSS Statistics 19.0.0.0 or 19.0 FP1, all of the items can be shown except the pivot tables. The pivot tables hang with the message “Processing” and they are never shown by Statistics 19.0 or 19.0 FP1.

Cause

For SPSS Statistics 19, we can generate two types of tables which can be controlled by the Edit > Options > Pivot Tables tab:
* Full Featured pivot tables ("Render tables with all features" option) or
* Lightweight tables ("Render tables faster" option).

These options are not available when using SPSS Statistics 20. For SPSS Statistics 20, tables are created using a new rendering engine called 'Light' tables by default. Automatically these cannot be viewed in SPSS Statistics 19.0 GA or 19.0 FP1 as the rendering engines are not compatible. Changes were made with the release of Statistics 19.0 Fix Pack 2 and now tables created using the 'Light' table rendering engine can be viewed in release Statistics 19.0.0.2.

An alternative in Statistics 20 is to generate tables using the 'Legacy tables' rendering engine. Selecting the option “Render as legacy tables” in Edit > Options > Pivot tables tab will generate pivot tables using the same engine as was used by SPSS Statistics 19.0.

Legacy tables may render slowly and are only recommended if it require backwards compatibility with SPSS Statistics 19.

Environment

Windows; Mac

Resolving the problem


1. For SPSS Statistics 19.0 or 19.0.0.1, please download and install the SPSS Statistics 19.0 Fix Pack 2.
https://www-304.ibm.com/support/docview.wss?uid=swg24031110

2. For SPSS Statistics 18.0.2 or lower version, a workaround is as following:
a) In SPSS Statistics 20, go to Edit > Options > Pivot Tables tab.
b) Select the "Render as legacy tables" option, then press OK.
c) Recreate the output. The new output with the legacy tables could be rendered in Statistics 18.0.2 or lower version.





Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

SPSS Statistics
Statistics Desktop

Software version:

18.0, 19.0

Operating system(s):

Mac OS, Windows

Software edition:

Grad Pack, Student Version

Reference #:

1592770

Modified date:

2013-07-17

Translate my page

Machine Translation

Content navigation