IBM Support

A Null Pointer Exception occurs with the result handler for an SCA invocation for WebSphere Process Server (WPS)

Troubleshooting


Problem

After you successfully upgrade to WebSphere Process Server Version 7.0.0 Fix Pack 4 (7.0.0.4), you receive a null pointer exception on the result handler for the Service Component Architecture (SCA) invocation while processing an application in the Business Space.

Symptom

The null pointer exception is thrown and the "EnrollmentException" process starts after the "Drop to paper" from your Java™ custom snippet. The Trace file and the SystemOut shows the following exceptions:
com.ibm.ws.sca.internal.binding.handler.SCAImportBindingHandler  Source ClassLoader:                                                                com.ibm.ws.classloader.CompoundClassLoader@71567156Ýappwar:EnrollmentExc  eptionProcess_V3_10App¨ Local ClassPath:      

com.ibm.ws.sca.internal.binding.handler.SCAImportBindingHandler  Target ClassLoader:                                                             com.ibm.ws.classloader.CompoundClassLoader@4dc04dc0Ýappwar:EnrollmentExceptionProxyApp¨ Local ClassPath:                                                    /apps/ibm/WebSphere/ProcServer/profiles/AppSrv01/installedApps/blwpdv01C ell01/EnrollmentExceptionProxyApp.ear/EnrollmentExceptionProxyWeb.war:/apps/ibm/WebSphere/ProcServer/profiles/AppSrv01/installedApps/blwpdv01Cel  l01/EnrollmentExceptionProxyApp.ear/EnrollmentExceptionProxy.jar          
Parent: com.ibm.ws.classloader.ExtJarClassLoader@6b716b71Ýserver:0¨    
Delegation Mode: PARENT_FIRST             com.ibm.bpe.invocation.sca.SCAInvocationHandler.createInvocationResult(SCAInvocationHandler.java:870) RETURN                                      
----- invocation result b impl -----                                      
message:                                                                
-------------------------------                                          
type  = java.lang.NullPointerException                                  
value = java.lang.NullPointerException                                  
-------------------------------        
state: EXECPTION                      
correlationId: null

Cause

This issue results from duplicate plugin Java archive (JAR) files that are generated by the upgrade process.

Resolving The Problem

To resolve the problem, complete the steps in the Business Space is unable to load with a "dojo is not defined" error document. These steps correct the duplication issue with the shared library JAR files, which resolves the null pointer exception.

[{"Product":{"code":"SSQH9M","label":"WebSphere Process Server"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Business Space","Platform":[{"code":"PF002","label":"AIX"}],"Version":"7.0.0.4","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
15 June 2018

UID

swg21592745