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Running gsk7capicmd command on IBM HTTP Server to determine password expiry date results in Error: 101

Troubleshooting


Problem

Attempts to run gsk7capicmd command on IBM HTTP Server (IHS) to determine password expiry date results in "Error: 101".

Symptom

Run the gsk7capicmd command as mentioned in the Technote 1588312

For example:
-------------------------------

C:\Program Files\IBM\GSK7\bin>gsk7capicmd -keydb -expiry -db "C:\temp


\plugin-key.kdb" -pw WebAS
Error: 101

Please refer to the GSKCapiCmd User's Guide for the meaning of the error.

Error id: GSKKM_ERR_KEYDB_NOT_EXIST
Details: C:\temp\plugin-key.kdb

-------------------------------

Cause

SSL encryption is not yet enabled for communication between IHS and WebSphere Application Server (WAS).

Diagnosing The Problem

Check the following:

  • Check if SSL encryption is enabled for communication between IHS and WebSphere Application Server (WAS).
  • Check if plugin-key.kdb file exists in the location 'C:\temp'.

Resolving The Problem

Use of the gsk7capicmd command to check password expiry date can only be run if plugin-key.kdb file exists.

The plugin-key.kdb file gets created at the time when you enable SSL encryption for the communication between IHS and WAS.

If you do not have the plugin-key.kdb file, then the above error is expected.

You can continue to work with IBM HTTP Server even after April 26.

[{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Integrations: WebSphere","Platform":[{"code":"PF033","label":"Windows"}],"Version":"7.1.2","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21592487