Troubleshooting
Problem
A Windows error 1722 occurs when uninstalling the trial version. Since the previous version needs to be uninstalled before installation a new version of Rules for .NET, this prevents from upgrating to a newer version.
Cause
The installer application does not have all the files needed to successfully uninstall the product.
The trial version may have been installed without all the prerequisites.
Environment
Windows
Resolving The Problem
Delete all ILOG registry entries and manually delete the ILOG installation directory (C:\Program Files\IBM\WebSphere\ILOG Rules for .NET by default).
To delete the registry entries:
- Run the command regedit from Start > Run.
- In the menu do Edit > Find... and search for ILOG
- Delete the folder or the individual key and use the F3 key to move to the next occurrence.
Typically the folders/keys to delete will look like:
- HKEY_USERS\...\Software\ILOG
- HKEY_USERS\...\Software\Microsoft\VisualStudio\10.0\ToolboxControlsInstaller_AssemblyFoldersExCache\HKEY_LOCAL_MACHINE_Software_Microsoft_.NETFramework_v4.0.30319_AssemblyFoldersEx_IBM WebSphere ILOG Rule Web Controls
- HKEY_USERS\...\Software\Microsoft\VisualStudio\10.0\ToolboxControlsInstallerCache\ILOG.Rules.Web, Version=7.1.140.4122, Culture=neutral, PublicKeyToken=...
- HKEY_USERS\...\Software\Microsoft\VisualStudio\10.0_Config\InstalledProducts\ILOG Rule Studio for .NET
- HKEY_USERS\...\Software\Microsoft\Windows\CurrentVersion\Explorer\MenuOrder\Start Menu\Programs\ILOG\IBM WebSphere ILOG Rules for .NET
- HKEY_USERS\...\Software\Microsoft\Office\Excel\Addins\ILOG.Rules.Office.Excel.AddIn
- HKEY_USERS\...\Software\Microsoft\Office\Word\Addins\ILOG.Rules.Office.Word.AddIn
- HKEY_USERS\...\Software\Microsoft\Office\Word\Addins\ILOG.Rules.Office.Word.RuleflowUI.AddIn
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Document Information
Modified date:
15 June 2018
UID
swg21592392