Unable to Close Work Order

Technote (troubleshooting)


Problem(Abstract)

"Could not change Work Order XXX status to CLOSE. Record already exists for Site=XXX, Work Order=XXX, Asset=XXX.".

Symptom

When trying to close a work order, the following error is received:

Could not change Work Order XXX status to CLOSE. Record already exists for Site=XXX, Work Order=XXX, Asset=XXX.


Cause

A record already exists in the ASSETHIERARCHY and/or ASSETHISTORY table.

Resolving the problem

Delete the faulty Work Order record along with any associated tasks from the ASSETHIERARCHY and/or ASSETHISTORY table.

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Document information


More support for:

IBM Maximo Asset Management
Work Order Tracking

Software version:

6.2, 6.2.1, 7.1, 7.1.1, 7.5

Operating system(s):

Linux, Windows

Reference #:

1592382

Modified date:

2014-05-23

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