IBM Support

Windows Application Log - "Error returned by ANServer: 0x80007000E" - Sterling Gentran:Server for Microsoft Windows

Troubleshooting


Problem

"Error returned by ANServer: 0x80007000E Not enough storage is available to complete this operation." shows in the Windows Application Log. No data will process, and neither the Gentran UI nor the Audit Log will open.

Cause

The Translation Objects field of the Directories tab of the Configuration window was populated with an invalid entry. In the particular issue that originated this article, the entry was only two back-slashes. That caused all attempts to import, export, or translate to go into infinite loops, which filled the transaction log of the SQL database and the ProcAuditLog_tb table of the database. That, in turn, puts the Audit Log in a state where it cannot be viewed, and the Gentran UI in a state where it cannot be opened.

Diagnosing The Problem

First you see multiple instances in the Windows Application Log of an error.
The first line reads Error returned by ANServer: 0x80007000E" and the second line reads
"Not enough storage is available to complete this operation." When checking the available space on the hard disk, however, there is plenty of space available. The Gentran UI will not open and neither will the Audit Log. No processes that use the translator will work, in particular imports, exports and attempts to process files containing raw EDI data, but they will go into an infinite loop. This is an indication that the database transaction log is full. You may or may not see a pop-up error of "[ SQL Server]The transaction log for database 'GentranDB' is full".

Once that is resolved, You get a separate pop-up error saying that the "TempDb is full" when trying to open the Audit Log.

Once that is resolved, you can view the Audit Log and see that it is full of errors that a particular translation object cannot be found. If you go to Tools > Configuration and select the Directories tab, you will see that the Translation Objects field contains an invalid entry.

Resolving The Problem

  1. Using the Windows Task Manager, go to the Processes tab and stop any and all instances of tx32.exe, gntxengine.exe, and unattend.exe that may be running in that order.
  2. Per the instructions in your Microsoft SQL Server documentation, truncate the transaction log of the database.
  3. Stop and restart the services, then you should be able to open the Gentran UI (also known as EDIMGR or Desktop)
    Attempt to open the Audit Log. If you get a pop-up error that says that "TempDB is full", then see in order the following two links. If the first one works, you do NOT need to view the second one.
  4. http://www-01.ibm.com/support/docview.wss?uid=swg21534432
  5. http://www-01.ibm.com/support/docview.wss?uid=swg21538592
  6. Once the database table named ProcAuditLog_tb has been cleared per the above article(s), you should be able to View the Audit Log.
  7. If you see a long series of errors indicating that a translation object cannot be viewed or cannot be accessed, do the following:
    1. Go to Tools >Configuration.
    2. Select the Directories tab.
    3. Adjust the entry in the Translation Objects field and click the Apply Button.
    4. Close Gentran
    5. Stop and restart the services.

[{"Product":{"code":"SS6V3G","label":"Sterling Gentran:Server for Microsoft Windows"},"Business Unit":{"code":"BU055","label":"Cognitive Applications"},"Component":"Performance","Platform":[{"code":"PF033","label":"Windows"}],"Version":"5.3.1;5.3;5.2","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg21592177