Application Support Install into Pristine ITM 623 Hangs or displays severe errors

Preventive Service Planning


Abstract

With applications at 6.2.1 IF3 level, once Next is selected on the ITM installation panel "Install Prerequisites", the ITM panel disappears and no error messages are indicated. Also, there may not be any log entries for this error. In some cases with later fixpack levels of ITM 6.2.1, you may see a "Severe Error" message and the installation will eventually hang. The Workaround solution will apply in each case.

Content

Additional Symptoms:

In later levels of 6.2.1 application support, 6.2.1 FP3 or FP4 and once Next is selected on the ITM installation panel "Install Prerequisites", a series of messages are displayed resulting eventually in a "Severe Error" and subsequent hang of the installation: "Checking directory C:\IBM\ITM for locked files" (pops up for few seconds).

followed by:

"Stopping services to upgrade java"

and then:

"Checking directory C:\IBM\ITM for locked files"

and then:

"Removing IBM Java2 Runtime Environment, please wait".

and then after a few minutes (it appears to hang), another message:

"Failed to uninstall"

then:

"Unable to copy a file to the drive where Program Files exists, cannot continue."

a final pop message entitled "Severe Error" is displayed referencing ITM's abort log.

(a message under this one "Installing IBM Java2 Runtime Environment, please wait." is there also but is hidden because of the other "Severe Error" message that is displayed).

Selecting "Yes" or "No" for this message will hang the installation.

In the log, one can see errors where ITM is trying to run java, etc, which does not exist on the DVD image. The DVD README.TXT contains a workaround for this issue:

Workaround:

- You may experience a Java upgrade error on windows when running in an environment where IBM Tivoli Monitoring V6.2.3 Fix Pack 1 has been installed, during a pristine (first time) install of IBM Tivoli OMEGAMON on z/OS V4.2.0 application support.

The Install Prerequisites window may disappear when selecting Next or while processing the java upgrade, result in a message "Failed to uninstall". Subsequently, this may require you to end the installation via windows Task Manager. More than likely you are attempting a pristine (or first time) app install, not an upgrade. Follow the rest of the instructions in this section to resolve the issue by installing IBM Java v1.5 jre on your system.

Note: Installing IBM Java v1.5 jre on your system will not affect ITM's runtime usage of v1.6 Java. It is only used temporarily to satisfy the dependencies that v4.2.0 app support needs for its installation - the installation that is needed for pristine install into V6.2.3 FP1 base environment only.

Also, as far as the windows operating system and its associated applications are concerned, installing IBM Java v1.5 jre should have no affect as long as you answer NO during steps 5 and 6 below and you de-select all browsers as recommended in step 8.

If the TEP and TEPS are installed on the same windows system, locate file ibm-java2.exe (IBM Java v1.5 jre). It will reside in:

<ITM Home>\CNB\java subdirectory.

If your TEPS is installed on a different windows machine than your TEP, either:

(a) copy the <ITM Home>\CNB\java\ibm-java2.exe from the TEPS machine

to the TEP machine.

or

(b) download ibm-java2.exe using URL:

http://<TEPS_host_name>:15200/java/ibm-java6.exe

(TEPS must be running)

Now that ibm-java2.exe has been located and resides on the TEP windows machine, follow these steps to install IBM Java v1.5 JVM:

(1) Run ibm-java2.exe and wait for a dialog window to display. If a pop-up windows appears wanting you to confirm the uninstall entitled "Confirm Uninstall", then do not continue with step 2 since IBM Java v1.5 JVM is already installed. V4.2.0 application support should be able to install into ITM V6.2.3 Fix Pack 1.

(2) On the pop-up window, select the language from the drop-down list and click OK.

(3) Click Next on the Welcome page.

(4) Click Yes to accept the license agreement.

(5) Accept the default location for installing the JRE or browse to a

different directory. Click Next.

(6) Click No on the message asking if you want to install this JRE as

the system JVM.

(7) If another JRE is currently installed as the system JVM, you are prompted to overwrite the current system JVM. Click No.

Note: Overwriting the current system JVM may cause applications depending on the current JVM to fail.

(8) Click Next on the Start Copying Files window to start installing the JRE.

(9) On the Browser Registration window, de-select all browsers that are currently checked.

(10) Click Next.

(11) Click Finish to complete the installation.

If this IBM Java v1.5 jre installation was successful, you can now perform the V4.2.0 application support installation.

After successfully installation of the V4.2.0 application, you may remove the installed IBM Java v1.5 JRE since it was only necessary for your installation into a pristine V6.2.3 FP1 environment. Only remove IBM Java:

V1.5 JRE, if you now longer have to install any more V4.2.0 application product support. To remove IBM Java v1.5 JRE from your windows system, first select "Programs and Features" --> "uninstall a program", look for name listed: "IBM 32-bit Runtime Environment for Java2, V5.0.".

Select this for uninstall and a wizard will run and guide you through the uninstall.


Cross reference information
Segment Product Component Platform Version Edition
Systems and Asset Management Tivoli OMEGAMON XE for CICS on z/OS 4.2.0
Systems and Asset Management Tivoli OMEGAMON XE on z/OS 4.2
Systems and Asset Management Tivoli OMEGAMON XE for CICS TG on z/OS 4.2.0
Systems and Asset Management Tivoli OMEGAMON XE for DB2 Performance Expert for z/OS 4.2.0
Systems and Asset Management Tivoli OMEGAMON XE for DB2 Performance Monitor for z/OS
Systems and Asset Management Tivoli OMEGAMON XE for IMS on z/OS 4.2.0
Systems and Asset Management Tivoli OMEGAMON XE for Mainframe Networks 4.2.0
Storage Management Tivoli OMEGAMON XE for Storage on z/OS 4.2.0
Systems and Asset Management IBM OMEGAMON z/OS Management Console 4.2.0
Systems and Asset Management Tivoli OMEGAMON XE for Messaging for z/OS 6.0.1, 6.0.0, 7.0, 7.0.1
Systems and Asset Management Tivoli OMEGAMON XE for z/VM and Linux Linux zSeries 4.1.0, 4.1.1
Systems and Asset Management Tivoli Composite Application Manager for Transactions for z/OS z/OS All Versions

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

Tivoli Monitoring Version 6

Software version:

6.2.1, 6.2.3

Operating system(s):

AIX, OS/390, Windows, z/OS

Reference #:

1592173

Modified date:

2014-04-18

Translate my page

Machine Translation

Content navigation