IBM Support

When launching a workflow from a FileNet Business Process Manager eForms for P8 form entry template, the following error is generated: Can not launch the Workflow. No form Template has been specified on the Lauch Step

Troubleshooting


Problem

When launching a workflow from a form entry template, the following error is generated: Can not launch the Workflow. No form Template has been specified on the Lauch Step

Cause

This is an unsupported feature of the P8 Application Engine and WorkplaceXT with P8 eForms. 

The problem is in the type of workflow - "regular" workflow vs. workflow associated with P8 eForms and with Workflow policy. If the user creates a workflow which does not use P8 eForm (this is what is being referenced as a "simple" or "regular" workflow) and set this workflow to the document entry template, launching the workflow from the confirmation page works fine. If the workflow launch involves opening an eForm template, the launch fails. This is the feature that was never implemented due to design limitation.

Resolving The Problem

Be aware of this limitation when following the documentation to set up the launching of the Workflow manually via the Entry Template. This limitation is not mentioned in the "IBM FileNet P8 documentation >> User Help >> Actions, preferences, and tools >> Work with tasks >> Manually launch a workflow >> Launch from an entry template that includes a workflow definition".

[{"Product":{"code":"SSTHRT","label":"IBM Case Foundation"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"eForms for P8","Platform":[{"code":"PF033","label":"Windows"}],"Version":"4.0.2","Edition":"All Editions","Line of Business":{"code":"LOB45","label":"Automation"}}]

Product Synonym

P8eForm

Document Information

Modified date:
17 June 2018

UID

swg21590851