CCM ETL tasks running too long to complete

Technote (troubleshooting)


Problem(Abstract)

Attempts to run the IBM Rational Change and Configuration Management (CCM) Data Collection Jobs results in the Work item ETL running for over seven hours with IBM Rational Team Concert (RTC).

Symptom

Under the Reports > Data Collection Job Status page of the CCM web UI, the Workitem ETL task took 7 hours to complete during a week day, and 3 hours during the weekend.


Cause

The database was running an "ANALYZE_TABLE" job against the database on a daily basis, which is also run through the ETL jobs. This was identified in Defect PM59246.

Environment

RTC 3.x hosted with Oracle Database, but this issue can be seen with other database vendors as well

Resolving the problem

The ANALYZE_TABLE command is already run by the ETL jobs, so it is redundant to have it run twice. Identified in Defect 197238, and fixed in RTC 3.0.1.3, the ANALYZE_TABLE command can be disabled through a new parameter in the Data Warehouse connection page named: Automatically update the database statistics.



To resolve this issue, complete one of the two options below:

  • Disable the ANALYZE_TABLE job from running automatically or,

  • Upgrade to RTC 3.0.1.3


Leverage the Jazz Community

Jazz and Rational Team Concert have an active community that can provide you with additional resources. Browse and contribute to the User forums, contribute to the Team Blog and review the Team wiki.
Refer to technote 1319600 for details and links.


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Document information


More support for:

Rational Team Concert
Reports

Software version:

3.0, 3.0.1, 3.0.1.1, 3.0.1.2, 3.0.1.3

Operating system(s):

AIX, IBM i, Linux, i5/OS

Reference #:

1590790

Modified date:

2012-04-11

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